Effects Error "Could not load settings below" [SOLVED]

On opening some effects, Clip Fix for example, I get a Message warning “Clip Fix: Could not load settings below. Default Settings will be used.”
The effect will work just fine, not sure what or why I’m getting this error.

Thanks in advance. For everything Audacity :slight_smile:

WIndows 10 , Audacity 2.1.3 .exe installer

If you have recently installed Audacity and have had an old version installed previously, you may have used settings in old versions that are not valid in the new version. If that happens, then rather than loading invalid settings, the effect will reset to its default settings. Future uses of the effect should then default to the last (valid) settings used.

I have kept current, that doesn’t seem to be it. Some of them seem to ‘reset’ to the error message on closing.
New information - It appears it is ‘seeing’ settings for a different plug in, the parameters it is 'rejecting don’t seem to match the plugin.

Ok, what is doing is trying to load the parameter from the previously used/saved effect. I saved the sole parameter for Clip FIx as a user preset (Parameters=thresh=“21.000000000000”). Closed Audacity, reopened. Clip Fix held that, however when I open Adjustable fade, the error pops up with the ‘could not load settings below’ as Parameters=thresh=“21.000000000000”

I note that the presets I saved in Clip Fix show up in Adjustable Fade.

It seems to be coming up on some of the '25 Audacity Nyquist plugins.

This is at the bottom of the pluginsettings.cfg

Parameters=Threshold=“200” Width=“20”
Parameters=DC_Block=“0” Noise_Floor=“-70.000000000000” Parameter_1=“50.000000000000” Parameter_2=“50.000000000000” Repeats=“1” Threshold_dB=“-6.000000000000” Type=“Hard Clipping”
Parameters=freq=“60.000000000000” q=“1.000000000000”

Audacity 2.1.3 has not been released yet. You may in fact have a dangerous early testing version that could potentially destroy your data. What does it say for “commit id” at Help > About Audacity…, click “Build Information”, then scroll to the bottom?


Try exiting Audacity and delete pluginsettings.cfg and pluginregistry.cfg (to remove any duplicate plugins that may exist)


Deleted the .cfg files solved the problem. Thanks

It was the new RC2 from Feb 20 I upped it from 2.1.2 to see if it would fix the problem. (which you solved :slight_smile:

OK, that one is safe as long as no errors get into the AUP file such as by hand edits of the file or imported audio files contain emoji or control characters.