Effects are not real-time disappear from view after being run

Audacity 3.2.1, 64 bit
Windows 11

Two related issues: 1)My effects generally do not work in the new real-time effects button on the left. However, the effects do generally work if run the old-fashioned way from the effects menus. For example, I can amplify, compress, etc.
2)However, effects that are essentially meters do not even work properly when run from the effects menu. For example, True Peak meters, of which I have two, You Lean and Melda’s MLoudness Analyzer. That’s because these meter-type effects seem to run, but immediately disappear after they run. Thus I cannot see the results. Nor do they display the results of the last test when I go back in. Thus, I have no way of knowing what the true peak level of a given project is.

BTW, This problem also prevents me from adjusting EQ settings in real time during playback, as I formerly could.

Of the two issues, #2 is the most urgent, since I can generally work around issue 1.

I tried reinstalling the affected plug-ins as 64 bit, per a previous forum. Didn’t help.

Also from a previous forum, I went into C:\Users\MyName\AppData\Roaming\audacity, and renamed the files “pluginregistry.cfg” & “pluginsettings.cfg”,
as “pluginregistry-old.cfg”, “pluginsettings-old.cfg”). This made more plug-ins visible, but didn’t fix my above problems.

Any suggestions? Thanks so much.

Using the effect menu, when you click Apply, it applies the effect to the track. For a analyzer, this necessarily means that nothing happens and the window disappears.

Use analyzers as realtime effects instead. Both Youlean Loudness Meter 2, MLoudnessAnalyzer and MAnalyzer work just fine for me.

Thanks for replying. In real time effects, the “analyze” button on MLoudness Analyzer is missing, so I can’t analyze the file. I tried just clicking the Audacity play button and letting the file play through fully, but the result was nonsensical (“silence”). My other program, Youlean, does not even appear in the real effects menu, despite it being on the old effects menu. Am I perhaps missing something?

Adding to my last reply, I just reversed my changes from yesterday in C:\Users\MyName\AppData\Roaming\audacity, which brought back Youlean. However, when I click the “apply” button, even when I open Youlean from the real effects button, Youlean again just disappears. And if I try the Audacity play button with Youlean showing, it crashes Audacity. Also, I noticed that other Melda plugins, like mcompressor, do not lose their “apply” button in real effects like mloudness analyzer does.
I am thoroughly confused. Never had these problems in many years of use until I upgraded to Audacity 3. Any ideas out there? Thanks so much.

So Audacity 3.2 is experiencing birthing pains with Real-Time Effects.

  1. You can check to see if your issue still exists in the current 3.2.2 alpha which you can download from here: https://github.com/audacity/audacity/actions. Locate the uppermost item with a green check mark. Note that in the second column you may see the word “release-3.2.2”. If it doesn’t say “release-3.2.2”, go further down the list. Click on the black ink immediately to the right of the green check mark, then scroll down to the bottom of this next page where you can locate a build appropriate for your system. In order to download it, you might have to log in.

  2. You can also check the 3.3.0 alpha nightly build here: https://nightly.link/audacity/audacity/workflows/build/master where new features are tested. However, these builds are more likely to have new untested features and less likely to have fixes to existing problems.

Disclaimer. Do not use alpha builds for production work. Use at your own risk.

Thanks so much. I will try what you suggest. For now, I have been using 3.1.3 again, and things are working smoothly.