Edits affect more than selected area


First post. Have checked the manuals and previous posts, please excuse any oversights or lack of etiquette…

Windows Vista Home Premium
Audacity 2.0.3

I’ve recorded a section of audio and am now trying to edit it, however the edits keep affecting an area greater than the selection. It seems that the edit is being performed on an area that includes the selection but IS based on blocks of about 5.9 seconds each. By that I mean if I try to silence the selected area, it will silence a portion of audio of 5.9 seconds long that includes the selection. If the area that I select crosses over the edge of that wider area, the portion of the audio affected includes another great chunk (5.9 seconds long) of the file to cover the part of the selection not within the previous chunk.

Images attached to illustrate my description.

Thanks in advance for any help.

Kind regards,
next block of about 6 seconds.jpg

please excuse any oversights or lack of etiquette…

We’re not particularly delicate – or bashful.

That behavior is normally a “Snap-To” problem, but your screen shots show Snap-To not selected.

You can zoom into the area in question and make it easier to see what you’re doing.

Drag-select an area bigger than your edit and Control-E zoom into the selection. Control-3 zooms out a little bit and Control-F zooms out full. I live in those three zoom levels.

You might also de-select Update Display in Audacity > Edit > Preferences > Tracks. That’s the one that causes the screen to flip left and right while you’re trying to set an edit. You should put that setting back when you record. That can be a handy check on your live recording progress.

Did you save your show? Do that now if you haven’t already. Try and avoid dates and punctuation marks. Today is 20131215 or 2013-12-15 ISO Dates. Dashes are OK.

Click in the Snap-To box and restart Audacity. Now click it off. Does it still leap to odd times?


Update to the latest Audacity 2.0.5 from here: http://audacityteam.org/download/windows .

Then Edit > Preferences, choose Directories on the left then set the temporary directory to a working drive that you have permission to write to and which has at least 10 GB of space. Restart Audacity.


Thanks for your replies. For some reason the file had been saved in the programme files folder, after saving in a documents folder the problem seems to have been resolved. 2.0.5 here I come…

OK so you had saved an AUP Audacity project file (probably I should have guessed that from the title in the Audacity window), and you did not have permission to write to the project’s _data folder in Program Files because you are not running as an administrator.