edit preferences

I am using audacity 2.3.3. When I go to edit preferences I get the FFmpeg library not found dialog. So I click on the FFmpeg Library Locate button and I get the “Audacity needs the file ‘avformat-55.dll’ to import and export audio via FFmpeg” message. So I browse and get and fill in the location of the avformat-55.dll file then click ok and ok again. But when I go to edit preferences I just get the same message routine again? Note: I am trying to set up the FFmpeg library to import m4a files. Any suggestions how I can get this working?

Because Audacity links to the FFmpeg dll, it requires a compatible version of FFmpeg.
When a compatible version of FFmpeg is installed, Audacity will normally find it without requiring user interaction.

See this page in the manual for obtaining a compatible version of FFmpeg: https://manual.audacityteam.org/man/installing_and_updating_audacity_on_windows.html#winff

Hi. I am having exact the same problem now. I use 2.4.0 version and I cant locate FFmpeg.
I have done instaliing step by step using the wiki instructions (https://manual.audacityteam.org/man/installing_ffmpeg_for_windows.html) and it didn`t help .

What am I doing wrong? Here is my log.
log.txt (9.65 KB)

The final line tells the tale:

Error: Failed to find compatible FFmpeg libraries.

It appears that you don’t have a compatible version of FFmpeg installed.
Try these instructions to install a compatible version of FFmpeg: Installing and updating Audacity on Windows - Audacity Manual

The link you give me sends me to this page (attachment 1) and then to this page (attechment 2), what is exact link I put at my first message. I already done this steps. I made it successfuly at the other one pc, but at my own laptop it doesn`t work.

The problem how I see it, that finder doesnt see the avformat-55.dll file. I point the path to this file manualy, it does exist at the folder, where I point the path. When finder opens the location it whants to see the file with resolution "avformat.dll" (attachment 3), and ofc it cannot sees it. Then I switch option to show all files and it shows the file (attachment 4). And when I double click it nothing happens! It still says, that file doesnt located.

Please, I ask you to pay attention to my bug, and please help me fix it.

I have the latest 2.4.1. and ffmpeg 2.2.2. installed on my win 10. I also attach the latest log.

Have you tried the ZIP version?

Yes, I did. It doesn`t work too.
log.txt (16.5 KB)

Try updating Audacity to the 2.4.1 version, and select the option to “Reset Preferences” during the installation.

Done. Still finder doesn`t see the file.
log.txt (16.5 KB)

Has this ever worked on that Windows 10 computer with other versions of Audacity?

No, it is the first time I instal the program at this laptop. I have started trying when it was 2.3.3.

and you couldn’t get Audacity 2.3.3 to recognise FFmpeg either?

Yes. It started from the very beginning

It sounds like it could be some kind of problem with permissions, but then I would expect other problems to occur as well.
Are there any other problems you see on this computer?
Does Audacity work correctly other than the FFmpeg problem?

I am sorry, it`s been a while.

No, there are other errors. When I push record button the error -9999 appiears.

Is Audacity running in a sandbox environment?