Edit Metadata dialog in export multiple "hides" behind main export dialog for every track after the first


Following the instructions on FAQ:Bugs - Audacity Manual to report a bug: I’m using Audacity 3.2.4 on Debian Testing (12 - bookworm, kernel 6.1.0-9-amd64), running Wayland.

Per the title, when I go to do a multiple export, as soon as I click “Export” I am presented with the “Edit Metadata Tags” dialog for Track 1.

I can change metadata, but then when I click “ok” the “Export Multiple” dialog comes back to the foreground, apparently focused (objects are clickable) but buttons don’t work and it makes it look like Audacity crashed.

What is actually happening is that the metadata editor for Track 2 has priority (focus?), but is hidden behind the Export Multiple dialog.

If I press Enter repeatedly (it’s the only key that seems to work - Escape doesn’t), specifically for the number of tracks that I am trying to export (minus one) then the export starts normally, indicating that the “hidden” metadata editor is actually receiving my keyboard inputs (essentially, I’m triggering “ok” in each hidden window) despite it being “hidden”.

I tried to drag the “export multiple” dialog somewhere else, but like a lot of GNU/Linux software (I don’t think this happens on Windows?) trying to drag a dialog will drag the whole “window tree”, and since the metadata editor dialog is smaller than the export dialog, it stays hidden.

Is there a way to force the “Edit Metadata Tags” dialog to go on top of its parent?


This doesn’t happen on my Windows 10 computer using Audacity 3.3.3.

Have you tried 3.3.3? Does this occur with the AppImage ?Linux | Audacity ®

You issues could be related to a local Debian build. In which case you may wish to report the trouble to them.

I don’t see your issue in Audacity’s open metadata issues: Issues · audacity/audacity · GitHub

None that I know of.

I have now (both repository and AppImage) and it still happens. With that said…

I created an Arch Linux VM and it works correctly there. I’ll report to Debian.

I followed the FAQ to report the bug; should I have reported it on GitHub instead?


It wouldn’t hurt. However, this is above my pay grade. I’ll ask @waxcylinder and/or @LWinterberg, perhaps they can give you a better answer.

We’re currently reworking the exporter; the metadata editor should be paginated in the future when exporting multiple files.

This is great, thanks!

This topic was automatically closed after 30 days. New replies are no longer allowed.