Edit Chains dialog does not add the command[SOLVED]

Audacity 2.0.1 installed from packages on Kubuntu 12.10

In the “Edit Chains” dialog, I can “Add” a new chain but I’m completely unable to edit the chain on the right side of the dialog. For example: the “Insert” button shows a list of commands but when I select select “Click Removal” and click “OK”, nothing is added to the chan.

It’s perhaps a little unintuitive, but you have to double-click the item or select it then use Space in order to add it to the “Command” text box:
http://manual.audacityteam.org/o/man/edit_chains.html .


Thanks Gale, I get it now. Should have read the manual :blush:

This is not solved in 2.0.5 or 2.0.6. I first tried the Debian 2.0.5 package and then built 2.0.6 from source. Same result for both. I can add/delete a chain name ok, but on the right side for the steps of the chain the only thing possible is inserting a blank line. That blank line can be moved up/down, but that’s the extent of what can be done. Double clicking or hitting space brings up a command dialog window, but nothing can be typed into the fields and “edit parameters” is greyed out. Highlighting a command from the “choose command” list and clicking ok does nothing.

As a workaround it is possible to edit the txt files in the Chains directory directly, but this GUI function is clearly broken.

Disregard my prior post, it does work. It’s just incredibly bad GUI design.

The reason why people scuffle with this is because the “Edit Chains” pane shows “Chain (Double-Click or press SPACE to edit)”. That is incorrect advice!
The individual steps shouldn’t be double-clicked, it’s the command selection in the “Select Command” pop-up that needs to be double-clicked.

This portion of the GUI definitely needs re-work. At a minimum please remove the incorrect advice from the “Edit Chains” pane.

What would you suggest?
If you’re not a programmer, perhaps you could make a mock-up in Gimp.

Yes they should if you are editing an existing command rather than adding a new one. Double-click or SPACE or ENTER on the selected existing command opens that command pre-selected in “Select Command”. Then ENTER or SPACE immediately opens the parameters dialog for that command (if it has parameters).

When you are inserting a new command, yes. Or press SPACE or ENTER. The problem seems to be that we use the same dialogue when editing or inserting a command but have not made the workflow intuitive when inserting commands.

We have to be mindful of making this work for the visually impaired who rely on screen readers. But how I would do it is that when you choose a command in “Select Command” (including moving from one command to another), the parameters (if any) for that command should be automatically selected (and so the ENTER/SPACE/double-click to select the parameters would then be un-necessary).

So if you accept the default parameters, all that would be needed for the sighted user is to select the command to insert and click OK.

I disagree. It is not incorrect.


Don’t shoot the messenger. If it’s so brilliantly implemented then why does it surface so often in the forums??

How about a single left click to highlight/select and then a right click to bring up a pop-up with all possible operations against the selected item? And consistently follow this mechanism throughout? Yes, I know, too easy and too intuitive. :unamused:

I never said it was brilliantly implemented. I said it was “a little unintuitive”.

It does not come up as a complaint all that often, but I can’t agree that removing the text from the Chain window will help those who want to go straight to editing a pre-existing command.

We don’t tend to use right-click in dialogues so it would not be consistent with other dialogues unless we changed those.

I think the procedure for editing the command is OK but the procedure for inserting a new command not so good.


So to open a command for editing, you would left click on the command, then right click on the command, rather than double left click the command?