Echoes when recording overdub

I’m on Windows 7 and have uninstalled my old Audacity and downloaded the latest version from the link on here.
The problem I am having is this:

  1. I record a guitar strumming a set of chords, then finish and rewind to the beginning, then
  2. I click the record button to record a lead pattern whilst listening to the playback of the chords, so it’s 2 separate tracks I’m recording, both of them acoustically through condenser microphone.
    But when I click playback, the 2 recordings sound terrible, as if I’m in an echo chamber, I’m fairly new to all this so can’t figure out what I’m doing wrong??

both of them acoustically through condenser microphone.

Sometimes it’s good to be very wordy about how you’re doing that. Model numbers? Mixers?

You might get that if you were recording “Everything On The Computer” instead of your microphone. That’s a valid setting on many computers.

Look at the device toolbar and make sure that just your microphone or mixer or thing is selected and not Stereo-Mix or What-U-Hear.

If you like recording YouTube sound or other streaming music, that’s exactly not what you want for a live performance.


Also make sure you have turned off Windows sound enhancements and all sound effects in the sound card: Audacity Manual .


And as I think about this, make sure:

Audacity > Edit > Preferences > Recording > [X] Overdub is the only thing selected in that panel.


Thanks Koz,
Got it in one! My problem is now fixed, your last suggestion worked perfectly, no box was ticked :slight_smile:

If software playthrough was causing echoes to be recorded as you suggest, that can only mean you are recording the wrong input (or not using headphones, or sending Audacity playback from the mixer back to Audacity to be recorded). If so, you should fix that, otherwise you will still end up recording the previous tracks into the new one.