Echo

Dear all,
AS I do`nt have a studio and using Blue yeti mic, how can I get rid of ECHO?

Are you getting an actual echo, “Hello… Hello… Hello…” Or room reverb/reflections, “Heellloooooooo…”?

If you are getting distinct echos, make sure you’ve selected the USB mic as your recording device (i.e. Not one of the selections that records soundcard output). And, wear (sealed) headphones, or turn-off your computer speakers so the sound can’t echo-back into the mic.

For reverb, try another room, try to dampen the reflections in the room, and get close to the mic (so the direct sound is much louder than the reflected sound) and make sure the mic is in the cardioid/directional setting.