Echo when recording vocals!?

why is there an echo sometimes when i record vocals. i dont even add the echo effect, it automatically add it when im recording. can anyone help me with this?

With little information to go on:
Use headphones for monitoring and not loudspeakers, and keep the volume down to avoid the sound “spilling over” into your microphone.
Also, in “Edit > Preferences > Audio I/O” make sure that “software playthrough” is NOT selected.
Don’t record in the bathroom, caves, tunnels or similar environments.