Echo on playback, nothing gets rid of it [SOLVED]

I’ve searched this forum for a fix, and nothing seems to work.

I am using a Rode NT1000 mic. with a Behringer mixer. They sound great on the headphone output. I plug the mixer into my Toshiba Satellite using a mic. to USB output cable and record using Audacity 2.1.0. When I playback what I have recorded it sounds like it’s in a tunnel.

Yes, I do have Software Playthrough (on/off) unchececked in the Transport tab. I have even disabled my laptop’s mic. I even tried turning the mixer’s headphone output all the way down.

Anything in here:


The echo may not be the only problem.

mic. to USB output cable

The output connection on the Behringer mixer is almost certainly not microphone level. What’s the model or part number of the adapter?


Unfortunately, I have already checked that, and it didn’t help.

When I right click on the speaker icon, go to Playback Devices, right click on Speakers and go to Enhancements, I have Disable all sound effects checked. Sound effects which are now unchecked include Environment, Voice Cancellation, Pitch Shift Equalizer, Virtual Sound, and Loudness Equalization.

Up and to the right is a box that IS checked called Immediate mode.

Down below, the Setting is set to None.

There is no mention of a “Noise Suppression” or “Echo Cancellation” setting.

When I right click on the speaker icon and choose Recording devices, I have every other device disabled. The USB PnP Sound Device is all that is enabled, and it is green checked. When I right click that and go into Properties, there is no Enhancements tab, and no tab has anything about Sound Effects. The Levels tab has it set to 50 (half way), and the Custom tab has AGC checked.

It still echoes.

There may be something to do with that not being the right connection, but it doesn’t seem likely.

I have a Behringer Xenyx X1204 USB.

As you can see in the photo of the back it has a three pin mic. connection output. I have a female connection to a male USB that I connect to my Toshiba Satellite. I’m attaching a pic. of the connector.

The mixer produces great sound through its headphones output, but when I record sound on Audacity and play it back, it has an echo, nothing like it sounded when I heard it on my headphones through the mixer.

By the way, thank you all very much for your time.

Can you post a sample of that in WAV then we can check if it is like a tunnel on our systems. See How to post an audio sample.

What are your settings for each box in Audacity’s Device Toolbar?


That mixer will connect directly to your computer with a USB cable. Why are you using an audio to USB adapter?

It’s the wrong adapter. The three-pin connection “Main Out” on the back of the Behringer is high level or volume, not microphone level. The adapter is expecting microphone level. You could have significant distortion in the connection because of the mismatch.

That and you will only get Left or Right sound of a stereo show, not both.

The correct USB cable is a “Printer Cable” or USB A to B.


When I try the printer cable that came with the mixer, it doesn’t seem to pick up any audio on Audacity when recording (the line is completely flat). Also, when I unplug it to playback the sound on my computer, it says, “Error while opening sound device. Please check the playback device settings and the project sample rate.” Leaving it plugged in doesn’t get that message, but it doesn’t play anything back through the headphones, which is no surprise, since it didn’t seem to record anything anyway. This is a brand new cable, so, surely it works. Do I need set something a certain way for it to work properly?

Thanks again, for everyone’s time.

When you connect the USB cable, are you choosing the Behringer USB Audio CODEC as Recording Device and Playback Device in Audacity’s Device Toolbar?

If you connect that cable while Audacity is open, do Transport > Rescan Audio Devices in the Audacity menu bar.

If you still have issues with that cable, try following the full procedure including reboot in the green box “Detecting USB and Firewire devices” on this page:

Also you could try another USB cable.


I finally got it working with the printer cable!!! :slight_smile: …but it still has an echo. :frowning:

Are you applying effects in the mixer?

Have you gone back into Windows Sound, Playback tab, right-click over the Behringer Xenyx USB > Properties and turned off all sound effects and enhancements? Do similarly on the Recording tab.


I didn’t have any effects on, on the mixer, but then I thought I would try them out. Putting the Program Parameter to 10, which is supposed to be a Chorus effect, actually makes it sound normal.


Anyway, I thank you all for your time. I wouldn’t have sorted all this out without you.