Echo in headphones when multi track recording

Aiight… Most of these question start off the same way and mine is no different…lol
I am very new to Audacity and this situation is really making me go crazy. I am using a Samson C01 mic, Behringer UB802 mixer which connects to a iMic and into the USB of my new HP laptop. I have music recorded on one track. I want to be able to talk over the music while it is playing back for my Podcast show. Well I can hear the music playing, I can hear myself talking, but there is an echo everytime I say something. Now the echo is not picked up on the recording, just in my headphones… WHAT am I doing wrong here!! In the settings tab, I have the “Play track while recording option selected” and also the other one too (I forgot what it says, but it is the option right below this one). Can someone please help?

Try de-selecting the other option (Software Playthrough). This is probably the problem - it means you’re monitoring the incoming recording via your hardware and then, with a slight delay, the same signal via software. The Software Playback option is there for older or low spec audio devices that don’t allow simultaneous monitoring of playback and recording.

When I deselect “Software Playthrough” I cant here it as Im recording. It does still record what Im saying into the mic, I just cant here it simultaneously. I am using a new HP laptop running Vista… can this be the problem? Also, I am using a Behringer UB 802 mixer. Please help.

Awesome! Thanks for the swift reply. It really works. I de-selected ‘software playthrough:play new track while recording it’ and the echo disappeared. I found it on audio preferences. Thanks again. :smiley:

yeah I have the same problem. I don’t want to turn this option off, I want to be able to hear the new track though headphones over top the others in perfect sync.
I’ve viewed the help forum on the Windows Mixer, but still unsure if this actually fixes this issue. Any help would be appreciated

Here’s my setup:
XP (SP3)
IBM NetVista Integrated Sound Card (not using USB)
AudioBuddy mic preamp
Audacity 1.2.6

Software playthrough will ALWAYS cause a delay (hence the echo) and there is no way round that other than switching it off (it is off by default).
Using the Windows Mixer to enable hardware playthrough is the solution (enable playback for the input that you are using as well as the output from Audacity).