Echo - Get rid of it

I’m recording audio and guitar and finally got my headphones to work with “software playthrough”. But there is always an echo. How do I turn off the echo effect?

Note that using a USB microphone is not the best way to record overdubs. These microphones are great for podcasters who just want to record their voice and are not worried about syncing to music. The problem with these microphones is that the only way you can hear yourself in your headphones is by turning Software Playthrough On. Software playthrough introduces its own delay (different from latency) which you will hear in your headphones. Tests on the same system used for the latency test below revealed that the Software Playthrough delay was 65 milliseconds. This doesn’t sound like much, but it’s like hearing your voice coming out of speakers 70 feet away. If you are serious about overdubbing, get an inexpensive mixer and a good microphone to go with it.

thanks for playthrough delay tip. But my main problem is echo with simple recording. If I just say “test 123” on record I get an automatic echo. No headphones involved. How do I turn it off is my question.

To get rid of the echo, turn off “software playthrough”.
However I guess there’s some reason why you want to have software playthrough turned on, so you’ll need to give full details of your set up - what operating system, which version of Audacity, what sort of microphone, what sort of headphones, how it’s all connected up, what you are trying to achieve and so on.

Are you recording “Mix Out” instead of one of the standard inputs like Line-In? That will give you a one-computer-late echo. The Windows setups for recording internet audio are openly hostile to recording a live musical performance.


I know this is probably gonna sound stupid and I’m like a year late, but how do you get to the options to change everything that you did?

Transport > Software Playthrough (on/off). If it appears checked (on), click it to turn it off.

You can also turn it off at Edit > Preferences and choose “Recording” on the left (Audacity > Preferences if you have a Mac computer).

If you have more questions please start a new topic in the Windows, Mac or GNU/Linux board according to what operating system you have.