Echo/double recording effect when pasting into existing file

This was touched on in a post of May 17th, 2013, entitled “Recording sounds like it’s recorded twice” which only related to recording phone calls/messages.
My situation is that I’m using Audacity 2 for Mac to edit an interview I recorded. I’m trying to paste another couple of sentences into the interview. I first record 20 seconds of silence which appears in a separate track beneath the main track/file I’m working on. I then paste the silence into the insertion point in the main track to make a space where the additional sentences can be pasted. So far so good. Then I record a couple of sentences at this point, which also appear as a separate track beneath the main file. Plays back fine. Again, so far so good. But when I paste this into the main file, although it fits perfectly, I get the echo/sounds as though it’s recorded twice effect.
What is causing this & how do I deal with it?
Also, I next want to paste some music into the interview. Should I do so in the same way as I described above?
Many thanks.

No need to go through all that. First go to Audacity > Preferences > Tracks and make sure that “Editing a clip can move other clips” is checked. Simply record your new bit (onto a new track), cut it from the new track it was recorded on and paste it into the spot in the main track. The new audio clip will be inserted into the track and the following audio will move to make room.

As an aside, please say “track” when you mean track, not “file” - it makes it confusing when you mix those terms.

Did you cut the audio from the new track, or copy it? If you copied it you will have two copies in about the same place on the time line after you paste it into the main track.

This tutorial may help:

– Bill

Many thanks, Bill. I’ll let you know how I get on.

Your advice on cutting & pasting a clip into the main track worked perfectly. Thanks. (To recap, I use Audacity 2.x with Mac OS X 10.9.4)
I now have a problem with importing music clips.
When I use File/Import/Audio to import a music mp3 a) The mp3 does not appear within the project as a separate track beneath the main track b). It is mixed with the very beginning of the main track. It does not mix with, or appear beneath, the main track at the point where I positioned the cursor. c) Because it does not appear as a new track, I cannot cut & then copy it into the main track at the point where I want it heard, that is after where it is mentioned in the interview. d) When I import a second mp3, it joins the first at the beginning of the main track, so the two mp3s are mixed simultaneously with the main track! e) Finally, the music is much louder than the interview/main track and because they are already mixed, I cannot find a way of adjusting the balance.

To sum up, I would prefer to place the music clips separately within the main track, to illustrate points made in the interview, rather than have them mixed as background to the interview, although this will serve if the first model is not achievable.

The main issue seems to be, how do I import music mp3s into the main track at the points which I choose?

Good, glad that was cleared up.

That is very strange. I have never seen that behaviour. File > Import > Audio always imports the audio file into a separate track. Please try starting with an empty project and do File > Import > Audio on two different MP3, WAV or AIF files and tell me what happens.

See above. Imported files are meant to appear in their own track.

Again, I have never seen that behaviour.

Please try the experiment of importing two audio files into an empty project and tell me what happens.

– Bill

So where does its blue waves physically appear? Have you tried scrolling down to the bottom of the project, or View > Fit Vertically?

Importing at the cursor point is a feature request - Audacity does not do that yet.

You can’t. If you import a file it will appear at the bottom of the project, starting at time zero. Scroll to the bottom of the project (DOWN arrow will get you there). Cut the imported file. Click in the main track where you want to paste, then paste.

If you haven’t made separate clips in the track, you can paste insert at the cursor whether “Editing a clip can move other clips” is enabled or not.


Many thanks, Bill & Gale.
The cut & paste system solves the problem.
A minor problem that does remain is that the track pasted into the main track often ‘overlaps’ into the main track, either losing its first couple of seconds or cutting the last second or two of the preceding section of the main track.

That should not happen. Single-click at the point where you want to paste into the main track.

Don’t drag a region in the main track. If you do that, the region will be replaced with the region you are pasting. That will alter the length of the track, unless the region being replaced has the same length as the region being pasted.


Make sure you do not have a region selected in the “main” track when you paste the new material into it. See Selecting Audio

Have you solved your importing problem? Have you tried Gale’s suggestion of doing View > Fit Vertically to see the newly imported track? Have you read the tutorial I linked to?

– Bill

I am pasting 90 second music mp3s into a 20 minute interview mp3. Earlier problems raised in this correspondence have all been solved. My current problem is that the short music tracks are much louder than the spoken interview into which I am pasting them. How do I lower the volume of the music tracks, or raise the volume of the spoken interview, or simply equalise the volume of both?

Use the envelope tool.
– Bill