Dubbing Vocal Files w/o Yellow Vertical Lines?

When i try to compile multiple tracks together, like vocals over a song, theres a vertical line thats yellow appears, that automatically connects one vocal file directly in place at the end of another sound file, and i dont want that cuz it messes with my vocal placement exactly where i want it. is there a way to get rid of that yellow vertical line that moves your file in place of another file?

You must be using Audacity 1.3.x.

You have two options:

  1. If you can, delete some silence off the end of the clip that’s getting in the way, or delete some silence from the beginning of the clip you’re trying to place. Audacity won’t let you overlap clips that appear on the same audio track.

  2. Move the clip you’re trying to place to a separate track. Once you do that you can either highlight both tracks and click Tracks → Mix and Render (to mix the two together, make sure the volume and pan settings are reset before you do this), or you can simply adjust the volume and pan controls separately for each track.

Zooming in to magnify the waveform should also help you with this.