DTS import question


Hopefully this is a quick and simple to answer question. If not… sorry.

I’m running the Audacity 2.1.3 with ffmpeg and lame libraries as they are recommended by Audacity (if you want that functionality) on Windows 10 and I use 64 bit apps whenever offered the option.

I’m having NO troubles getting 5.1 imported from digital video media, but I notice almost invariably that the Center channel is delivered WITH clipping, and sometimes the LFE channel exhibits this characteristic also.

It is my understanding that these channels are extracted from the matrix’d data stream (not as technical as I’d like, but hopefully conveys the right intent), and that players decode in a way that will not produce clipping if you aren’t otherwise overdriving your speakers. Yet these two different kinds of output don’t match each other. At least not for me, so far.

Am I doing something wrong? Or is this pretty typical of surround data extraction vs playback?

If it is typical, is there a good strategy to correcting the clipping other than a pre-processing pass to “Amplify” with reduction to 0.0 max peak?

I’d much rather there were an import option that analyzed the whole file first and gave totally unclipped output in the first place, but… I have yet to be educated on it =D


If by apps you mean VST plugins, Audacity can only use 32-bit VST2 versions of plugins, even if your machine is 64-bit.


Thanks, Trebor, for your response. Still, my system/preferences were more informational than relevant to the actual question, just in case it made a difference.

Nonetheless, I managed to find an acceptable answer through several other sites. Ultimately it lead me back to ffmpeg’s documentation where I learned how to control the channel gain on extraction.

Apparently, Audacity does not take advantage of this option and over-scales the whole because of it. Bummer.

If you are comfortable working with the command line, you can manually extract DTS audio on a per channel basis. Rather than using an “=” in your channel mapping use “<” instead… this will ensure that not only will you not get clipped channels, even their summation will not clip (assuming I read it correctly).

I did not test this myself. Reason? For my particular application, all I really wanted was a duplication of the audio downmixed to Stereo properly for further processing. Which ffmpeg does VERY well with the right options set (even in accordance with broadcast standards fwtw, which is a bunch of very exciting formulas I just didn’t have time to delve into, but if you want to look at it it’s ref’d by ffmpeg here), and only costs me the LFE channel… which after several days of testing adds almost nothing to a stereo mix on quality headphones - so… buh bye LFE, hello 6 extra hours a day.

It would be awesome if someone who programs for/with Audacity incorporated an “ffmpeg import command line” option, but… it’s a small thing to do manually and probably a pain to program, so… here’s to wishing /cheers! and on with the show.

Thanks again, folks!

If you’re happy using command-line interfaces, try SoX … https://en.wikipedia.org/wiki/SoX#External_links

Thanks, I’ll be checking that out.