Dragging Files To Audacity 2.1.2 Unsuccessful.

Mac OS X 10.11.4
Audacity 2.1.2
Source File: http://www.fosshub.com/Audacity.html/audacity-macosx-ub-2.1.1-screen-reader.dmg

To Whom:
Computer had a crash. I installed the latest Audacity (2.1.2), whereas previously I had the previous version on the computer. Basically, this was a clean new install. (BTW, this happens even when I reloaded the app from Time Machine.)

I installed version 2.1.2 successfully but what I get is this issue…

I find I cannot drag audio files, for instance, aiff, mp3, and m4a files. These are what I normally work with. The dragging processes I tried were dragging from Finder to the Audacity icon in the Dock, and opening Audacity and attempting to drag from Finder to the Audacity window .

Previously these processes had worked fine. The first method would open a different Audacity window per audio file, the latter method would place all the audio files into the one already open Audacity window.

Perhaps it has something to do with LAME library or the FFMPEG plugins? To be honest, I’m not sure how or where to install them, nor which one of these and other necessary plugins to load after the DMG files are on my computer.

Any thoughts or suggestion would be appreciated.


Do they open up the conventional way? File > Import?

We try to stay away from words like “latest” and “previous.” those change depending on who and where you are. Was it Audacity 2.1.1?

All Lame does is let you export an MP3 at the end of your edit. I think Macs use QuickTime Services to open everything else, so yes, those should all slide right in.

Do they go through the “Emphatic Rejection” animation? Do they bounce away from Audacity? Or do they seem to work but nothing opens?


The screen-reader version is 2.1.1. You can drag files into that version. Into 2.1.2 you cannot, as it says in the 2.1.2 Release Notes.

In 2.1.2 you “should” be able to drag most file types to the Audacity icon in the Dock. It works for me on OS X 10.11.4 with a USB mouse.


From the hyperlink you posted, I found these two items under Imports and Exports
:black_small_square: (Mac OS X) Dragging audio files to Audacity’s icon in the Dock will only import the file for WAV, AIFF, AU, MP2, MP3, OGG, FLAC and M4A. Workaround: Rename MP4 files (audio or video) to M4A extension. Alternatively the files may be dragged to the Audacity icon in the folder where you have Audacity installed, dragged into the open Audacity window or imported using the Audacity menus.
:black_small_square: (OS X) Audio files cannot be dragged into the Audacity window. You can drag files to the Audacity icon in /Applications or in the Dock, or import the file from within Audacity.

The first bullet says that, “… the files may be dragged…into the open Audacity window ….

And yet the second bullet states that, “Audio files cannot be dragged into the Audacity window.”

This sounds like they are conflicting statements to me.

Yes, File > Import works.

Sorry about that Koz. With my background in the IT field I should have known better, and yes, version 2.1.1

It seems like it returns to the Finder window and its focus is on the files name that I dragged. Nothing opens in Audacity. And I get following when I do import and export (usually to a different format):

Exhibit Numb 1.jpg

True, but the first sentence of the second bullet over-rides the first, and we’ve decided to definitely fix the second bullet for the next release, then the first bullet will still be true. They are separate bug reports and the one in the second bullet is much more recent.


Aaah, thank you for that info.