Drag&drop is weird

I wanted to drag a 1.5 Gb wave file to audacity, no biggie. Only problem, I dragged it from Total Commander which subsequently became inaccessible for the ~50 seconds it took to load the audio file. I don’t have this problem with other audio programs. I’m running 2.0.3 still, gonna update right away and hope that fixes it. It’s something with accepting the file drop before or after loading (think before should be preferred in any circumstance).

Other audio programs are probably not copying the data from the file.

1.5 GB for a WAV file IS pretty big (equivalent to about 2.5 audio CDs). The absolute maximum size for a WAV file is 4 GB.

Do you have the problem if you drag a file from the desktop?
Does your computer have a single processor or more?

Same problem here with Windows Explorer & Windows 7 and a 1.3 gb wav file. What’s actually interesting is that the file is not locked while it is loading but it is locked while Audacity is drawing the waveform. On my system, which is pretty fast, I have time to demonstrate this:

  1. open up folders on two different drives one of which contains a very large WAV file (obviously 1.3-1.5 GB seems to work).
  2. start Audacity and resize it and the two folders so you can easily access all three.
  3. drag the extremely large WAV file onto Audacity then immediately drag its icon from one folder to the other.
    On my system Audacity’s loading progress dialog continues to show that Audacity is processing the load and the Windows Explorer Copy progress dialog shows that the copy is also happening at the same time. Close Audacity (you might also have to reboot depending on how much & how fast your RAM is and if the wave file got completely cached in RAM – but probably not). Delete the copy of the very large WAV file that you just made.
  4. start Audacity again (it should be sized so that it and and both of the folders are accessible).
  5. drag the extremely large WAV on to Audacity but this time wait until the file is loaded completely; Audacity should just sit there preparing to draw the wave in the track.
  6. quickly, before the wave is drawn, drag the extremely large WAV file’s icon from one folder to the other.
    Windows Explorer refuses to proceed with the copy until Audacity is completely finished drawing the wave. This makes little or no sense to me as the file lock should certainly have been released by this time.

As those of us who have delved deeply into the source code regarding file read/write know, there are lots of problems in this area; the Developers are well aware of this but correcting the problems would require a fundamental restructuring of this entire portion of the code (file load & save). This would require a major commitment in programmer’s time and testing rewriting a section of the code which works pretty well now (but not great) – the fatal flaws are very rarely exposed, the current idiosyncrasies have been around for many years and there are only a couple of real improvements available.

Additionally, wxWidgets (the external cross-platform library upon which the Audacity GUI & (most of the) file handling is built, has a new stable version (3, we now use 2) to which the Developers are now moving; there are many bug fixes in its file handling code so some of the problems we experience might go away soon .

That is only if you drag the file to the Audacity icon, I think. And for some reason I can still copy the file in that case between the time the Audacity progress dialogue completes and the time the waveform gets drawn.

If I drag the file into the Audacity window, then when I switch back to Explorer or xplorer2 while Audacity is still showing the import progress dialogue, the mouse pointer in the file manager has a rectangle attached to its base and it is not possible to move or copy the file to another folder.

You can start copying the file first and then import the file into Audacity while the file copy is being made.

Another solution is to choose the “read the file directly” option in the dialogue that appears in Audacity when you import the file. This does not do copy into Audacity and Total Commander should be unavailable for no more than a second or two. If you do not see that dialogue and don’t want to see it, just turn on the option to read directly in Import / Export Preferences.


This is exactly my problem. I’ve tried it in Renoise, same file same file exp (TC), Renoise accepts the dnd action immediately and I can use TC while Renoise is loading the file. So I’m sure it’s possible to not break the file mgr / dnd source. Not sure if Renoise would first check where the file resides. Any way you look at this, this is a bug. Renoise also definitely buffers the file, which is behaviour I want from Audacity too. IMO it’s just the order of things that are done on drop: read file → accept drop or accept drop → read file. Probably oversimplified but hey.

Yes, oversimplified, but hey, have you tried the solution that Gale proposed?
(choose the “read the file directly” option)