Distortion only when using Software Playthrough?

I’ve Googled this and dug through forums using “Software Playthrough” as search term. No luck. Distortion (click/crack) ONLY occurs when Software Playthrough is enabled. All Audacity meters show sound levels are not clipping or even close (peak is about -15). Preamp (see setup below) does NOT have headphone output. Help?

sample mp3:

Fender electric bass no effects, volume out about 3/4.
Digital MPA preamp, VU meter needle showing bass output at lower tenth of scale.
M-Audio Delta 1010LT soundcard control panel shows signal in green (-12 max) zone.
Audacity 2.0.3 on WinXP Pro SP3 w/lots ‘o’ processing power & memory.

The bass notes are very seriously unstable and they’re not clipping. I think the system is feeding back. The reason it doesn’t just scream at you like a bad rock night at the club is the system delays. That clip has a bad bit of sound every fraction of second or so. You could get that if you’re not recording directly from the soundcard, but instead from Stereo-Mix or What-U-Hear. When you activate Playthrough, Audacity sends your show sound back to the computer so you can listen. But with Stereo-Mix selected the computer promptly sends it back to Audacity – and up – and back – and up…

Your overall system volume is very slightly low, or you would be getting constant thumping in the show instead of cracking.

So it’s a Windows problem. Go into control panels and see what you’re recording from – or alternately, Audacity Preferences > Recording and see what that’s pointing to. If you like recording Internet Audio, those are the settings causing problems.


Both the Windows sound control panel and Audacity are set to receive the bass input from the same place where it is plugged in: M-Audio Delta 1010LT 3/4. I tried changing the far-right Audacity dropdown to “1 (Mono) Input Channel” but the distortion was exactly the same. NO Stereo Mix or What-U-Hear ANYWHERE.

Right now I’ve given up on Audacity & Windows --should na happen – and am trying to rig a headphone monitor to one of the preamp outputs, despite the fact that it wasn’t designed for headphones. I won’t know results until tomorrow afternoon after I’ve done some soldering and adaptering and plugging-in. Serious hardware mucky muck.

Will keep you posted. Sad to see no software solution!

The problem is not “clipping” it’s “skipping”.
You can see it clearly in the “spectrogram” track view as vertical lines each time a bit of data is dropped:
When playing back at the same time as recording, there is twice as much data, but not only that, it is having to handle continuous streams in two directions simultaneously (“duplex” transfer). What sample rate and bit depth are you using?

I’m not at the PC right now, but I seem to remember I bumped the sample rate 48000, while the bit depth is at what I’ve always called the “standard” 32 bits in Audacity preferences. Perhaps I’m pushing it a bit to far?

On the other hand, if the crux is making Audacity handle two very different streams when Software Playthrough is enabled, then isn’t my creating a headphone monitor at the preamp (routing an XLR output through an adapter to the phones) output a reasonable solutions?

Setting the Audacity bit-rate to 32-bit float will not cause a problem as that only affects the format in Audacity (sound cards don’t do 32 bit float so the sound card will just deliver in a standard supported format).

You could try 44100 Hz and see if that makes an improvement. Problems are common when people try to push the rate really high, especially with USB devices, but I’d have expected 48 kHz to work OK, particularly with a PCI device.

There’s quite a lot of things that can cause this type of problem. I’m afraid there is really no shortcut other than methodically working through the possible causes and checking them one by one.

Direct monitoring from the pre-amp avoids the problem (and gives you zero latency monitoring), but it would still be a good idea to try and find the root cause of the problem. A list of possibilities are described on this page: http://wiki.audacityteam.org/wiki/Managing_Computer_Resources_and_Drivers
Ignore the bit about “Audio cache” - I don’t think that ever really worked well in any version of Audacity and often caused problems.

On XP, defragmenting the hard drive is important, as is checking that DMA mode is enabled for the hard drive(s).

I’m not sure if it is listed there, but I’d also have a look at which interrupts the sound card is sharing in case there is another installed device that is getting in the way with a high rate of interrupts (the 1010 LT is quite an old design (as is Win XP) so interrupt sharing may be a bit below par compared with more modern designs. Swapping to a different PCI socket may be all that is needed (if you’re lucky :wink:)

Steve, thanks for all the details. I’ll get on that when I arrive at home.

The problem is not “clipping” it’s “skipping”.

I don’t know that I agree. Just looking at the waveforms gives you segments of increased and decreased volume at periodic points very typical of long form feedback. Just leaving off bits doesn’t do that.

It may be skipping as well, however.


Here’s a close-up of one of the discontinuities in the waveform:

Oh, I believe you, but I wonder if that’s not the only thing wrong. Koz

It’s the main thing that’s wrong - that’s the cause of that nasty crackle. If you put the track on spectrogram view and zoom in on a couple of notes full screen you can match the crackles with the vertical red lines.