Distortion (gargling noise) when recording vinyl or CD.

I am using Audacity 2.0.3. which I downloaded from the exe. installer, with Windows 7 64 bit Pro. the soundcard is from Creative and is set up at 24bit 96khz as is Audacity. Recording does not produce, what I would call, a proper waveform and the sound is severely distorted, like a gargling noise. I have read through the help pages and, to the best of my ability, set up everything as instructed, I am obviously missing something but, at the moment it is beyond me, can you give any advice? I have only recently bought my computer essentially for the high quality sound card and this is my first try at setting up Audacity in its new home. Thanks Mike T.

In Audacity, set the default bit-format to 32 bit float. This will not affect the recorded data (and will probably not solve the problem) but it will improve the precision when processing the audio.

Could you post a short sample (just a couple of seconds) in WAV format. (How to attach files to forum posts: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

Thanks for your quick response, here is the short sample, as requested. Mike T.
.aup (2.56 KB)

Thanks, but you’ve posted a .AUP file. We can’t do anything with that as it is not an audio file, it is just one part of an Audacity Project.

This article explains about Audacity Projects and how to create normal audio files: http://manual.audacityteam.org/o/man/audacity_projects.html

I hope that this one works for you. Mike T.
audio file .zip (959 KB)

The recording level is too low. Best to aim for a level that shows a waveform that is about half the height of a track.
The “gargling” noise is because the data is not getting from the input through to the hard drive fast enough, so little bits of data are being lost.

There are two approaches to fixing the latter problem. One is to reduce the amount of data so that the computer does not need to work so hard, the other is to try and improve the efficiency of how the computer shifts data from the audio input through to the hard drive. The first approach is easy to do - change the sample rate to 44100 - that will reduce the amount of data to less than half (with no loss of sound quality). That may not be enough on its own to completely fix the problem, but you will probably see a marked improvement.

Locating the data bottleneck and improving throughput is more difficult because there are so many possible causes for the bottleneck, and it may be a combination of factors.

If your sound card is a USB device, then the USB connection is the most likely problem. Don’t use a USB hub. USB keyboard/mouse are unlikely to be a problem, but should not share the same USB socket as the sound card. Other USB devices should ideally be removed. When you have it recording correctly you could try reconnecting other USB devices to see if it is safe to have them connected at the same time, but for now I’d recommend physically unplugging them.

External hard drives are another common cause - use an internal hard drive to store data. Recording relies on continuous data transfer, not just burst speed.

Other suggestions are listed here: http://manual.audacityteam.org/man/FAQ:Recording_-_Troubleshooting#skips

Hello Steve, the only setting that gives the ability to record is with the 96khz setting, 44kkhz gives a pulse signal, I have tried every setting and 96khz is the only one to make a recording. The sound card is built in to the computer also the hard drives and, apart from the mouse, there are no USB connections.
Regards Mike T.

I presume that you mean 44.1 kHz?

What do you mean by a “pulse signal”? Perhaps you could post a short sample.

Hi Steve, of course I meant 44.1khz. There is no signal using 44.1khz going to the sound cards Patch Mix screen, the signal strength meters do not operate. I enclose instead some screen shots, 1- of Audacity signal strength meters using 44.1khz, the red bars are there with or without an input signal from the amplifier and move only to the limit that is shown in the picture; 2- a picture of the sound cards Patch Mix DSP screen (a) when set up at 44.1khz; and (b) when set up with 96khz, on this picture you will notice that the sound card has recognised the programme as “vinyl transfer” along the bottom. I hope I have given you some useful information. Regards, Mike T.

I received a communication at 13.45 today, was it meant to be a response? there was no message. Mike T.

No screenshots :confused: