Distorted recordings from turntable-New problem

I’ve been using Audacity for about a year or so (2.1.0) on an iMac using El Capitan operating system (10.11.6). I used it last week to make several recordings of songs on old albums. Today, when I started, Audacity would not open. I thought I’d try the updated version. Downloaded it, opened ok, but recording quality was horribly distorted, with echoes, etc. Yet the monitoring meter rarely hit yellow. I removed the newer version (after an hour of trying things) and reloaded the 2.1.0 version. Got the same problem. I’ve followed trouble-shooting, tried everything i know of (not much), and still no luck. Surprising after it worked just fine 3 days ok for recording 10-15 different songs. Any suggestions are certainly welcome. I’m at a loss.

Is that a USB turntable, and did you select the USB turntable as your recording device?

Yes. It is a Stanton T92. Connected via USB. I did select turntable as the recording device.

I think I figured it out - maybe. I had a USB extension attached to cable from the turntable. I removed the extension and attached directly to computer. it seemed to work fine. Again this was Audacity 2.1.0 on a MacBook Pro with Mojave.

Do yourself a favour and download the latest Audacity version 2.3.2 (2.1.0 is ancient now - and many bugs have been fixed).

You can download 2.3.2 from here: https://www.audacityteam.org/download/mac/