Distorted backing track only when recording OD

Win 10 Aud 2.30 M Audio M Track Asio v4
I have used Audacity for 5-6 years. Wonderful DAW

I load backing track sounds good…then hit record and backing track distorts and pitch change on new overdub(guitar) recording.

To test I used an older project that was fine. Playing back fine, but if I try Record a new track into the project distorted and weird pitch change on new recorded track. (flat )

I have read thru FAQ…and manual. Tried all the latency tests ect. No other changes to computer. I use M Track as my sound card. Recorded the click track…checked settings.

This started about a week ago.
Made sure drivers up to date, I have recorded 100 or so projects without difficulty…


Audacity doesn’t change the backing track when you overdub, so what’s probably happening is you’re recording the backing track in addition to your performance.

Make sure you’re recording from your microphone or instrument pickup, not a “fake device” such as Stereo Mix or What U Hear.

The people who like to record on-line music or other content get burned with this because they forget to change the recording device back.


I use M Track as my sound card.

Just to be clear, you’re not using your regular soundcard at all? (The clock in a consumer soundcard can be off enough to cause a pitch-shift that’s noticeable to a musician.)

You can get distortion (clipping) when mixing because mixing is done by summation. You can reduce both tracks by 6dB (50%) before mixing, or you can export to floating-point WAV (which can go over 0dB without clipping), then re-import the mixed file and normalize before exporting to your final format.

Not using onboard soundcard. I am doing this as I have for about 5 years.
The downloaded file is WAV…
I just exported it to MP3,
Sounds fine… When I hit record with NO INPUT from my guitar…the backing track distorts ?

When I record the track it is a full step flat on playback…but is correct as I record in my headphones.

I have Reaper so will see how it works…however I greatly prefer Audacity…
I am no longer a pro musician…RIAA ANALOG guy had a 24trk MCI…Studer etc…Studio. Closed in 1983,so you can tell I am no kid…:slight_smile:
Major music biz burnout…I put it all under the bed until 5 years ago.

I download a backing track same as always…then play a couple takes…then record. Then the weirdness starts.

I record at even -12db same distortioon

I have older version on my Laptop…let’s see what happens…

Thanks for all the thoughts…
Analog Man in a Digital Playground…

I record direct to M Audio Mtrack USB . '71 Les Paul Custom,into Pod Pro…in stereo (twin mono) usb to Audacity as always 5 years… I really prefer Audacity for my simple purposes…have used Reaper and older Pro Tools…
Post to Soundclick and Souncloud…this is the first ever difficulty. I have 60+ tunes as I recover from years of rust…

I certainly am not what I was…just who I am now…and that;s ok…

Uninstalled Interface…then reinstalled after making sure old file deleted. Even reboot computer THEN reinstall…
Same with Audacity…now on 2.3 but this started before the upgrade,

I have friends doing “beats” that can;t understand how this issue has occurred…

Record with NO SIGNAL input and Backing Track distorts…recording is a few semitones more than a full step flat…

Thanks for reading and any ideas greatly welcomed… If this was on analog…it could easily understand the issue…but new to digital…

No tape…no razor blades… !

OK…same hardware,into Laptop… Works perfectly… So ggod news or bad… I think driver conflict…? I just recorded at varying levels way hotter than what was on DeskTop…I7…v old Lenovo I3 laptop…
Both with plenty of memory…

Audacity 2.12 …so on to needle in driver stack…

You are probably getting [u]dropouts[/u] in the recording and/or the backing track. Dropouts are related to the multitasking operating system and the “good computer” is probably running fewer background operations or it might be a faster computer. Don’t run any other applications and try to minimize the number of background operations. It could be a driver problem, but it’s not necessarily an audio driver… Any driver/application/process that “hogs” the CPU & data bus for a few milliseconds too long can result in buffer overflow (recording) or buffer underflow (playback/monitoring) and you get glitches in your audio.

Dropouts during recording will cause “glitches” and since you’re missing bits of the recording it may end-up playing-back at a faster tempo and higher pitch. Playback dropouts will create glitches/gaps and it may end-up playing at a slower tempo and lower pitch.

This is a “big subject” and there is a free online book called [u]Glitch Free[/u] about optimizing your computer for audio. (The book is geared toward live performance and minimal latency and if you’re not monitoring “live” through the computer you don’t need to minimize latency, but there is still lots of good information.)

Version 2.3
Still same issue. Garbled track when in Record…and record track id about a full step flat. I have had 6 years with great results…but I think it’s time for Reaper which I DO NOT like as much…but works well…
Sorry to lose my favorite DAW,
Tried deleting (difficult ) used revo deleted…but still won’t uninstall…thought to wipe clean and do complete reinstall 2.3

Ok on my old laptop…but for the last month or so…unusable on my I5 desktop…

So, are you saying that:

  1. Audacity 2.3.0 works fine on your Laptop machine.
  2. Audacity 2.1.2 works fine on your Desktop machine.
  3. Audacity 2.3.0 plays very distorted at the wrong speed when recording on your Desktop machine.

If that’s not what you mean,or not what you have tested, please clarify.

Steve, thanks for your interest.
about 5 years,same desktop. Something changed. I load a backing track previously recorded… Play…and sounds fine…
Now I record an overedub (all low gain) and the clean backing track is crackles, buzzes,and the OD is more than a Full step flat ?

I tried…load a clean track…then hit record with NO signal…backing track again has that crackling…buzzes and digital distoruion…NO input signal intentionally to see what might be doing this.

I load the track into Reaper…plays fine…hit record…also sounds fine. I have tried to delete Audacity but this is difficult. I have current version…I tried going back to a previous version…same problem.

I have old laptop…also with Audacity… Load the Same backing tracck…hit record and all is well. So there is something in the desktop that is causing this. I deleted Repear…still same problem.
I much prefer Audacity so I use the Laptop (win10)…but I would much prefer my I5 Win 10 desktop with YEARS of tunes I have recorded.

I have tried EVERY fix this form has generously submitted…but no luck so far.
Something is amiss when I Overdub/Record.
Luckily ? I have two broken fingers on left hand so not recording much. Took a fall broke a rib and left index and middle (still immobilized together)
I used to record RIAA tech in analog days,much easier to trouble shoot FOR ME.
Here is a project I did in AUDACITY before this problem…so was working well for my meager needs…

I just recorded an A triad…then OD’d the same A…recorded A is time delayed…so maybe ASIO.? But this works in Reaper. I have had Reaper on the computer for years unused…so not a recent install.
Latency (in preferences)
Buffer 100
Latency Compensation -130

Any thoughts or help greatly appreciated…

Sorry…meant to answer…
2.3 on I5 desktop…16 gigs Ram
2.12 on old Laptop…8 gigs

I have time to try to get this solved (if possible) as I can’t play with finger taped tpgether to heal…although I do cut the bandages to play… Doc is not happy…but I am empty without my recording…

Audacity does not ship with ASIO support (due to licensing issues), so you will not be able to record using ASIO.

Also, when ASIO is running, it tries to take exclusive control of the audio device, so it will interfere with non-ASIO applications. It’s OK for ASIO to be installed, but if it is running, then it is likely to cause problems for Audacity.

I will try to record with ASIO disabled…but I have used it in this configuration for 5+ years and hundreds of tracks… Latency issues promted me to search…and found a thread indicating to use ASIO4All…

Will give it a try…

23:29:53: Audacity 2.3.0
23:29:53: Trying to load FFmpeg libraries…
23:29:53: Trying to load FFmpeg libraries from system paths. File name is ‘avformat-55.dll’.
23:29:53: Looking up PATH environment variable…
23:29:53: PATH = ‘C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Intel\iCLS Client;C:\Program Files\Intel\iCLS Client;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\QuickTime\QTSystem;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Users\Ken\AppData\Local\Microsoft\WindowsApps;%DASHLANE_DLL_DIR%;’
23:29:53: Checking that ‘’ is in PATH…
23:29:53: FFmpeg directory is in PATH.
23:29:53: Checking for monolithic avformat from ‘avformat-55.dll’.
23:29:53: Error: Failed to load shared library ‘avformat-55.dll’ (error 126: The specified module could not be found.)
23:29:53: Loading avutil from ‘’.
23:29:53: Error: Failed to load shared library ‘.dll’ (error 126: The specified module could not be found.)
23:29:53: Loading avcodec from ‘’.
23:29:53: Error: Failed to load shared library ‘.dll’ (error 126: The specified module could not be found.)
23:29:53: Loading avformat from ‘avformat-55.dll’.
23:29:53: Error: Failed to load shared library ‘avformat-55.dll’ (error 126: The specified module could not be found.)
23:29:53: Error: Failed to load FFmpeg libraries.
23:29:53: Error: Failed to find compatible FFmpeg libraries.
23:30:23: Attempting to load LAME from system search paths
23:30:23: Loading LAME from lame_enc.dll
23:30:23: Error: Failed to load shared library ‘lame_enc.dll’ (error 126: The specified module could not be found.)
23:30:23: load failed
23:30:23: Attempting to load LAME from builtin path
23:30:23: LAME registry key exists.
23:30:23: Library path is: C:\Program Files (x86)\Lame For Audacity
23:30:23: Loading LAME from C:\Program Files (x86)\Lame For Audacity\lame_enc.dll
23:30:23: Actual LAME path C:\Program Files (x86)\Lame For Audacity\lame_enc.dll
23:30:23: LAME library successfully loaded
23:32:53: File name is C:\Users\Ken\Desktop\Music 2018\Stillwater Blues (Key of Am) 1st mix REC TEST.mp3
23:32:53: Mime type is *
23:32:53: Opening with libsndfile
23:32:53: Opening with libmad
23:32:53: Open(C:\Users\Ken\Desktop\Music 2018\Stillwater Blues (Key of Am) 1st mix REC TEST.mp3) succeeded

That shows that your system is struggling to work in “duplex mode” (recording and playing at the same time).

One thing to look at, is the “sample rate” for the device in the recording AND playback tabs of the Windows Sound Control Panel - ensure that they are both set to 44100.

Thank you your time and help. Maybe I will use Audaccity on my Laptop. But since all this…and recovering from thee broken fret hand…I learned Reaper…
It works well on my desk top…
Thank you again steve

Steve, thanks. I went to default sound setting and it was not 44100 ,so reset it… Also deleted my DI interface and reinstalled. Audacity works however I get the “drop outs” warning. I’ll search around and see what’s causing that.
Reaper and Audacity seem to play nice both installed

Thanks for your insights