disappearing radio buttons


I have had Fedora 24 running fine for a few weeks now and recently tried Audacity, 2.1.2. It seemed to install happily but is unusable as only the bottom half of the buttons at the top left; ‘record’, ‘playback’ etc, appear. What’s worse when I point at them most just disappear totally - as do some of the other symbols! I tried removing/reinstalling but with no luck.

Any ideas would be appreciated. Thanks, Adrian

Is that 2.1.2-4.fc24 (from the main Fedora repository)?

Does this look like the same problem: https://bugzilla.redhat.com/show_bug.cgi?id=1347053

Steve , thanks for reply.

It is indeed the 2.1.2-4.fc24 version - downloaded via the ‘software’ links included with the fedora.

The Bugzilla reports do seem to be the same problem - not clear to me that anyone had a solution but I may be just bamboozled by all the jargon! Will have another read but if you have any suggestions I’d be pleased.


Comment 13 appears to hold the answer:

Also are you or Fedora configuring wxWidgets with

–with-gtk=3 ?

If so, that is not officially supported by Audacity:

http://www.audacityteam.org/download/source/#instructions > .

Looking at the .spec file for wxGTK3 in Fedora 24…


…it seems likely that we are indeed configuring wxGTK with --with-gtk=3

So the answer (not a pleasant one) is that you would need to build wxWidgets 3 against gtk2, then build Audacity against that version of wxWidgets.

There are some general instructions for building on Linux here: http://wiki.audacityteam.org/wiki/Developing_On_Linux
Unfortunately they are a bit out of date, but mostly they should be correct. I’ve never built anything on fedora (I’ve never used fedora) so if you attempt to build from source and run into problems you may be best asking the fedora community. (We have detailed instructions for Debian based distributions, but I don’t expect they will be very helpful).

Thanks Steve - I’ll have a read through and see if I feel I’m up to it!