Digital crackling on all recordings

Hi there,

I’ve used Audacity (albeit relatively sporadically) for years to record DJ mixes. Line out of the mixer, into the Mac sound card and record. Simple.

I’m a serato user and play both files via serato and records via the thru function. Has worked totally fine for years.

Lately, everything I record has an aggressive digital ticking or crackling. It doesn’t normally start from the start of the mix but 10-15 minutes in and drops in and out throughout from there. I’ve managed to record one 50 minute mix without this in the last 6 months but everything else I’ve recorded has had the crackling. I used to use serato and audacity on the same computer with no problems and thought it may be an issue with the Mac struggling to both run serato and record the line input, so I changed to running audacity on another computer.

I thought it might be a bit rate/sample rate issue but am not very technical and can’t seem to work out the problem.

Can anybody advise? Even better, can anybody suggest a way to remove the crackling from previous recordings where I’ve kept the Audacity project file?

Any help would be appreciated as I’m about to quit using the programme soon as I’ve lost too much time recording unusable content.

Thanks

David

It’s fairly unusual to have crackling with the Mac’s internal audio, but it happens. Which version of Yosemite are you on? If it isn’t the latest, there were some fixes in the updates. And there is a new update, dated today that contains several audio security fixes that just might fix your problem.

  • Is the crackling in the entire recording, or just every few minutes?

  • Do you have Skype installed, or any other programs that might have background tasks (like BitTorrent, backup program…)?

I’m afraid filtering the crackling from existing recordings is probably out of the question. But we’re only able to judge that if you could post a short example (mono, wav, 10 seconds). See here for instructions on how to post attachments:

https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

Please, see the pink panel at the top of the page and let us know what version of Audacity you have. The latest version is 2.1.2 from http://audacityteam.org/download/mac.

Have you tried turning off WiFi? Have you turned off AppNap (right-click or CTRL-click over Audacity.app, then Get Info)?

Have you tried reducing “Audio to buffer” at Audacity > Preferences…, Recording section? Set it to 0 milliseconds then if playback breaks up, increase it in 10 millisecond increments until playback doesn’t break up.

Google Chrome may be a problem due to things it does in the background, even if Chrome is not running. You may want to disable the keystone agent Google Updater.


Gale

Hi both, thanks for your replies.

I have done all of the things in your post Gale and they seem to have solved the problem (about to fully check the mix later). Not sure which one issue it was exactly but seems to be fixed for now.

I’ll come back if it persists/reoccurs.

Thanks again,

David