Difficulty Saving File

Hi everyone,

I’m new to Audacity, and am trying to put together a podcast as a proof of concept project for my company.

I watched a few videos to get set up and recorded my first file with little issue. Afterwards, however, I couldn’t save it and haven’t been able to despite my best efforts. The message I get states that either I don’t have enough space, which I know is inaccurate (27 GB free) or I don’t have permission to write (which doesn’t make sense since I am the only user and the administrator).

I’ve pasted the error code below. I’m hoping someone can help me move in the right direction.

For reference I have a MacBook Pro (2016) / OS - Big Sur.

Thanks so much, and Happy Thanksgiving!

“timestamp”: 1637764246,
“event_id”: “e3ff619ca84f4264bb4accd68c7872c8”,
“platform”: “native”,
“release”: “audacity@3.1.2”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Macintosh”,
“version”: “10.16.0”
“exception”: {
“values”: [
“type”: “Error_Writing_to_File”,
“value”: “Audacity failed to write file /Ep. 1 - .\nPerhaps disk is full or not writable.\nFor tips on freeing up space, click the help button.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“log”: “17:15:04: Error: can’t create file ‘/ - Matt ’ (error 1: Operation not permitted)\n17:15:04: Error: Error copying the file ‘/Application New Project 2021-11-18 08-54-26 ’ to ‘/ - Matt ’.\n17:15:04: Error: File ‘/Application New Project 2021-11-18 08-54-26 ’ couldn’t be renamed ‘/ - Matt ’ (error 0: Undefined error: 0)\n13:26:56: sqlite3 message: (14) cannot open file at line 40021 of [1b256d97b5]\n13:26:56: sqlite3 message: (14) :40021: (0) .aup3) - \n13:26:56: sqlite3 message: (14) statement aborts at 4: [ATTACH DATABASE ‘/ .aup3’ AS outbound;] unable to open database: / .aup3\n13:26:56: DBConnection SetDBError\n\tErrorCode: 14\n\tLastError: Unable to attach destination database\n\tLibraryError: unable to open database: / .aup3\n”

I do not know what is causing this error; however, if you care to zip up your .aup3 file, then upload it to a public file server, then post (or PM me) the link, I’ll take a look at it.

Thanks so much! Is it possible to zip it without saving it initially? I tried exporting it and got another error message.

So you would have to save the project to have a .aup3 project file created. Typically, if you try to exit Audacity without first saving the project, Audacity will prompt you to do so.

'Export’ing would be a totally different thing.

Yeah, I’m guess I’m just worried that if I qui Audacity, I’ll lose the file completely since I can’t save it initially.

Your audio may have already been lost - I don’t know. I have no other tricks in my hat. Perhaps someone else does.

Perhaps disk is full or not writable.

That’s the kind of error you might get if you accidentally point Audacity to a drive or folder that doesn’t exist. And you might get that if you put a date or other complex characters in your filename.

-Dash- and Underscore are the only two safe characters in filenames. You might be able to get Macs to deal with strange characters, but the first time you try to send work to someone else or put it on-line, Blammo!!

Today is 2021-11-24. That’s one of the ISO date formats.

Also never point Audacity to external, network, or cloud drives.

Any of that ring a bell?


I’m having a similar issue. I was trying to save to cloud storage (Google Drive specifically). I was able to save when I pointed it at a local folder (Downloads).

Yes! This is bizarre and frustrating!
I’m not sure how I can make sure I have an upate that is saved on the drive, or do I have to pull it off the drive each time to use it?
I also tried forcing a ‘offline’ version of the drive folder it was placed within, but that also didn’t seem to work.

Please help!

I would highly recommend that you move projects to a normal folder on your computer’s internal drive before opening the project in Audacity.