Difficulty recording keyboard and computer audio at the same time; please help!

Hi there, I used to be able to do this without difficulty but somehow I’ve managed to confuse myself tremendously.

The situation: I want to record my electric keyboard, via my Zoom R8 interface thing, onto an existing audio track that I have in MP3 on my computer. In other words, I want to create just a single track in Audacity with me playing keyboard on top of the audio on this MP3 track. The ZoomR8 is doing what it’s supposed to (apart from sound being a bit tinny, but I think that’s the keyboard itself, and that’s a separate issue), but it’s doing what it’s supposed to because I can hear me playing on top of the track just fine through the computer speakers, but how to get Audacity to simply record as a single track what’s coming through the speakers as I play my keyboard over the Mp3, is apparently too complicated for me. I can record my keyboard by itself, and I can record the MP3 track by itself, and I can import the MP3 to Audacity and play it and play my keyboard over top of it but no matter what setting I put it on, it still only records one or the other (MP3 or my keyboard) when I try to record them together.

I’ve tried what seems like every combination of the host, playback device, recording device, and recording channels (unless I’ve missed one particular combination in my frustration!). I’ve tried enabling and disabling different recording devices in the sound menu on the computer itself. I’ve tried the specific recommendations for this kind of situation like here about the Wasapi setting (https://www.howtogeek.com/217348/how-to-record-the-sound-coming-from-your-pc-even-without-stereo-mix/), which also seems consistent with what Audacity recommends on its help pages. But it still doesn’t work for me. Is there any other settings that I should be checking to get this cooperating.

By the way, it does work to import the MP3 into Audacity and recording my keyboard as a 2nd track, but this is not what I want to do. The timing doesn’t match and my recording is slightly after each note on the track, and looking up how to fix that, I can tell just reading it, I will not be successful with that, so I just want to find out how to make a single track with my keyboard on top of the MP3 track. There seems to definitely be a way to do this (as per the above link), and I used to do this all the time, but somehow I must have changed some setting in the year or so since I last did this, because it’s just not working for me so something isn’t matching up properly.

I’ve tried on both my old Audacity and the very newest one which I downloaded today.

Any help would be appreciated, I’ve been working on it for days now! (I do have another, unrelated question, but mastering this is my first priority, haha).

Thanks in advance!

So Audacity can only record from one source at a time.

The loopback setting won’t work either for the same reason.

This is the way most people do it. To align the tracks you simply have to create the equivalent of a “clapboard” - you can press a key every beat in the first full measure, for example. Later just Mix and Render (or Mix Stereo to Mono) to put everything on one track.

However, I’m thinking since you have that wonderful mixer thing there, that you could pipe the computer headphones into say, channel 1 of the Zoom and the keyboard into channel 2 or 3. Play your MP3 from your 3rd party software and record the Zoom with Audacity.

For that matter, you could just record onto the Zoom and transfer to Audacity later.

This topic was automatically closed after 30 days. New replies are no longer allowed.