Difficulty building

Hi Guys,

I’m pretty new to Audacity and have been trying to get the build working over the last few days. I ideally wish to build with the ASIO drivers, but it’s hard going so far. Here are the problems I’m facing.

I’ve cloned audacity, and checked out commit 1322b40 (tagged Audacity-2.4.1).
I’ve cloned wxWidgets and checked out v3.1.1 branch (commit 379a404f - including submodules).

I’ve got Visual Studio 2017 professional and have built wxWidgets fine using the visual studio solution (as described in docs/msw/install.txt)

When I get to building Audacity is when I start getting issues. Firstly, I followed the instructions for building audacity from here using CMake. Although CMake was finding wxWidgets correctly via the environment variable, once I was building, it could not compile various files due to incomplete type definition (wxBitmap and others - I will provide more detail on request for CMake configure and build errors). I could not resolve this issue, so I accessed the same build document in the repo to build (win/build.txt) and it referred to the use of the solution file, which I successfully used. I confirmed that the ASIO drivers were being pulled in by inspecting the preprocessor directives.

After building successfully using the Visual Studio solution file, I built the installer and proceeded to install on my other Windows 10 machine. This was successful. However upon launching, I was receiving an “Unknown, unhandled exception” error, killing Audacity from the outset.

I have tried different things to see what might be causing the issue: I installed the release of 2.4.1 and then just inserted my audacity.exe (as I figured they use the same runtime dlls), but this created the same result. I’ve tried with wxWidgets 3.1.3 thinking that it could be this causing the issue.

I’m at a loss to know what is the issue. I have also noticed that the size of my audacity binary is a lot larger than the released version (16.3MB - even without ASIO support). My next attempt is to slot my non-asio build into the release install and see if that works.

If the actual release is built using CMake then perhaps there is a disparity between that and the Visual Studio solution build?

Any help would be greatly appreciated.


A quick update on this… I rebuilt without ASIO support and replaced the release binary with the one I have built and it seems to launch ok. This points to problems with the ASIO build.

Still having trouble with CMake :frowning:

Another update…

Seems like the Realtek ASIO driver issue has struck again. Removed the registry key as outlined in previous threads and it launches correctly.

Thanks for reading!

HI brother, I hope you are doing just fine!

A very very kind and noble soul put all of the steps on how to build Audacity on Windows platform using ASIO4ALL as well.
He even recorded a video! Check it out! https://www.youtube.com/watch?v=EKmgw-8uMwM&feature=youtu.be

Hope it helps.
Thank you!