different time in Audacity and other player

I did the update of Audacity 2.1.2. installed with Windows 8.1; the recorded time of a recording is not the time in a player. For example, when I record a project 60 minutes in Audacity, and I export this item tot the hard disk and play in Windows Media Player the actual time is a large number of seconds more. No 60 minutes, but for example 60 minutes and 50 seconds. I have also tried some older versions wit Audacity and now with the same problem. Until recently I never had this problems.

Please tell us exactly what you are recording. Give us the make and model number of the recording equipment.

Is the recording time more than 60 minutes in Audacity? You can use CTRL + F to check that.


I use Windows 8.1, the version 2.1.2 and the .exe installer, I only recorder music as mp3 in Audicity; if I play after recording in Audicity in Windows Player there are more seconds…

We cannot see your computer. Please tell us exactly how you are recording the music. Are you singing or playing an instrument or is the music playing on the internet or on a USB turntable or cassette deck?

Look in Device Toolbar and tell us exactly what the selected recording device says.

As I asked, is the recording time more than 60 minutes, before you export to MP3?


Most MP3’s from the hard disk on the computer for a radio program; If I put ten numbers of exactly 3 minutes from the hard disk in Audacity to make one project, Audacity says I have recorded 29 minutes and about 30 seconds; if I export this project after that to the hard disk again and play it in Windows MediaPlayer or an other player, the player tells it’s exact 30 minutes. That’s very strange, or not???

If you put 10 tracks of exactly 3 minutes each, end to end in Audacity, the total length will be 30 minutes.
If you put 10 tracks end to end in Audacity and the total length is 29 minutes and 30 seconds, then the tracks are not exactly 3 minutes each, even if Windows Media Player says they are.

That’s not true; I have tried it on a other computer with an older version of Audacity then Audacity says it’s 30 minutes and that’s exactly the same as in Windows Media Player… I have never had this trouble before…

For example, perhaps you are not reading the track length correctly in Audacity.

How exactly are you putting these files into Audacity? Dragging them in and moving them with Tine Shift Tool, File > Import > Audio… then Tracks > Align Tracks > Align End to End, or something else?

One explanation could be if you are cutting and pasting the songs. In Audacity 1.2.x, if you clicked after the end of a track and pasted, the paste would still paste to the end of the track. In current Audacity the paste is made exactly where you clicked, and so the combined track length after all the pastes could be longer than the combined length of the audio being pasted.


I do it with Tine Shift Tool, import audio-tracks

When you drag each track to start after the previous one, look for the yellow vertical line that shows you when the start of the dragged track aligns with the end of the previous one. Then the total length of the project won’t be longer than the combined length of each track.