Didn't save changes

Hi there, this is the first time I have been on a forum so apologies if I do anything wrong!

I did a load of work on an Audacity file last night and then stupidly clicked ‘No’ to Save Changes this morning. I realised what I had done and clicked ‘Cancel’ but it went ahead and didn’t save anyway. I’m on a Mac M1, using Audacity 3.4.1, but my Mac didn’t save to Time Machine or iCloud. I have looked in the Session Data folder for Audacity but it is empty. If, by some miracle, someone can help me find the file from yesterday, or knows how to restore to yesterday’s session , I would be very grateful! I’m not great at tech stuff - just a humble musician! - but any help would be wonderful, thank you!

Yes; someone recently suggested adding an “Are You Sure” double-verification. This request was not received well.

I think you are out of luck. :cry:

Did you close Audacity? Once you do that, the Edit > UNDO vanishes.

Quick note that Audacity doesn’t get along well with drives other than the local, internal one. My Time Machine saves to an external drive and I don’t use iCloud. I shuffle files around after I turn Audacity off.


I would vote for that! Followed by a ‘Just stop and think that you’re doing’ button :). Thanks for your reply :slight_smile:

Thanks for your reply Koz :). I did close it :(. Ah well, I’ll have chalk it up to experience. Not sure why it didn’t cancel the save when I clicked Cancel though…

Hi Jademan, I wonder if I could bother you again, please? I have another Audacity file that I have just discovered won’t open. It’s says Audacity can’t read the file. I saw on another thread that you have fixed this problem for people (I’m on a Mac) and I wondered if you would be kind enough to have a look at it please? You said to ‘zip it up, upload it, post a link’ - I’m not sure how to do that? I’m guessing I would have to post the link on the other forum?

Thank you!

Audacity 3.4.2 was just released. Give that a try.

So yes, I have done that in the past, but I have found I cannot do that anymore. If 3.4.2 doesn’t fix the issue, then you are going to have to hit up one of your Windows friends. See: Corrupt or Otherwise Broken Audacity Project Recovery

Hello and thank you :). Unfortunately, the update didn’t work :frowning: I’ll have a look at the link you sent me :). Our online concert is in 4 weeks and I have I still have another 32 songs to mix so hysteria is setting in, haha! :rofl: I really appreciate your help, thank you :slight_smile:

Hi Jademan :slight_smile:
I did as you recommended and asked a Windows friend to repair the corrupted file. It worked and he sent it back to me but I couldn’t open it and got the same error message - can’t read file. I uninstalled Audacity and reinstalled and also did this with an earlier version of Audacity and the Apple silicon versions but still the same.

This is the first I’ve heard of this. If you want, upload both projects and send me a link. I’ll take a look and see what there is to see.

Thank you :). He’s just having another go now and we will have a go together over zoom tomorrow morning but, if that doesn’t work, I will upload the projects. I haven’t done this before - do I just load them into dropbox or something and then send you a link to the folder? Sorry, I’m a bit thick! And, if you knew me, you would know that everything goes wrong around me :rofl: Thanks :slight_smile:

Hi Jademan :). I don’t know what my friend did but he has redone the whole process and sent it back to me and it works! I think he just re-ran the repair. I’m very grateful to you for your help and, as I know your time is precious, I’m glad we have found a fix this time. Thanks again :slight_smile:

Glad to hear you are sorted. :grinning: