Determining Record Levels

I’d like to record some vinyls on my PC, but i’m having some problems determining the correct Input level. I’ve followed some guides/tutorials on the wiki, and they advice me to adjust input levels so the ‘Red Clipping Indicator’ on the ‘Meter Toolbar’ doesn’t appear. (As described here:
Even if i put the recording (input) level and the output level of the source at maximum, the Indicator never appears. Although, my recording is seriously distorted then. The meter toolbar is also completely filled then, constantly pushing against the 0db limit.

If i lower both record level and output level my recordings sound good, but i’d like to record them at maximum level without distortion. That’s pretty much impossible without the Clipping Indicator.

I tried with Audacity stable and beta, same problem. A quick search on this forum yielded me no solutions.

Anybody knows a solution for my problem? Fyi: I have a Synq XTRM-1 turntable with a built-in line-out (but i have the same problem if i use the turntable phono-out > mixer > pc line-in). My PC has an Audigy 2 ZS Soundcard. I’m using Windows XP with the latest drivers for my soundcard.

I also have a question about this passage on the ‘Recording Levels’ page in the wiki:

Note that the achieved recording level is a combination of both the input level you record at and the output level of the source. If you find you achieve near maximum levels on the recording meter with only a very low setting on the input slider, this may lead to the recording sounding excessively close and un-natural. In this case you may want to cut back the output level somewhat if you can. Similarly if you can’t get close to maximum levels on the meter even when the input slider is on maximum, try turning up the output level.

What should be highest for optimal sound quality ? The Input (recording level) or the Output level of the source (line-in)?

Step one would have been to post in the forum appropriate to your computer and version of Audacity. I’m just going to start asking you those questions anyway and wasting time. I assume a PC because you said so. Running Windows and not Linux? And Which Audacity?

Referencing this picture:

The recording meters are in the extreme upper right. If you launch Audacity cold and click once inside the meters, they will operate without going into record and allow you to do testing without creating a file.

Turn off all your speakers and monitors and all that stuff. That can complicate things.

Every time I have to change connections on my Blaster Live! card, I have to go back to the books to make sure I get the right connector. Are you sure you picked Line-In?

Play a record (leave the speakers off) and set your level controls roughly the same (assuming multiple controls) and ooze them all up or down slightly until the meters bounce with peaks around -6 to -3. Can you get there? If you picked the Mic-In connector instead of Line-In by accident, you will never make it. The sound will either be way on the left of the meters or gross overloading and pounding zero. It should be possible to gracefully bring the music up and down through the numbers on the Audacity meter without any crazy level snapping or overload lights. All this should be done with the only sound in the room coming from the actual needle in the groove. No speakers.


Thank you for your answer.

I’m 100% sure that everything is connected right. Like I said, I can record my vinyl without any problems.
My real problem is that I can’t determine my maximum record level in a good way.

The Red Clipping Indicator (like on the image below, taken from this page) never appears, even if I max out all volumes, and my sound is obviously distorted/clipped (Bars are constantly pounding against 0db).

The indicator just doesn’t seem to work.

Like I said in my original post. I’m using Windows XP, and I tried with the lastest stable and the latest beta version of Audacity.

So your recordings are clipping, but the indicator isn’t lighting, right?

I get that problem if I use the M-Audio MobilePre at work and I set it up for mono operation. It’s bizarre and it drives me crazy. But if I record in stereo, the problem goes away and I can see the indicator light up.

The problem seems to be that your sound card drivers aren’t telling Audacity that the sound card input is clipping. I think that it’s up to the sound card to determine if an input is clipping. It’s up to Audacity to determine if the output is clipping. (Can someone confirm this for me? I’m not fully convinced.)

You can try upgrading your sound card drivers, but I’m not sure it will help. This is a problem I’ve had trouble finding a solution to as well. If you have a motherboard sound card, can you try that as an input to see if it works?

To answer your question about which volume control is more important (input or output), it depends on the equipment involved. Different pieces of equipment deal with lower volumes differently. Some equipment (like my Roland V-drums kit) has a noise floor that becomes audible if you set it up poorly. I had it set so that all the samples were playing at a pretty low volume, and I was compensating by turning up the output volume. This had the effect of raising the noise floor higher than it needed to be. I’ve since set the loudest sample (the snare, I think) to play at max volume, and adjusted everything to sound good relative to that. Now the noise floor is much lower.

Generally higher quality equipment will be better able to deal with running at a lower volume, but not always. You really have to listen carefully and see. If you can’t tell a difference, then chances are that nobody will ever know. My rule of thumb is to let the worst piece of equipment run at the highest volume, but if I do hear noise, then I take the time to test which volume control works better. 9 times out of 10, however, it makes no difference at all which piece of equipment is at a higher volume.

However, since all of my equipment is of similar quality, I generally just leave the input volume up on the sound card all the way and adjust the volume at the source. The reason I default to this is that it’s easier to turn a knob in the real world than in software. I only own one noisy piece of equipment (a model train sound effect generator, it’s so awesome) and I use it very rarely, so I never really have to touch the software volume control for day-to-day recording.

I have heard from an old teacher (a non-audio related teacher) that it’s best to have each volume level set to the same spot on the dial. For instance, if you’ve got both input and output set at 70% and your clipping, turn them both down to 60% instead of turning one down to 50%. I’m not convinced it makes a difference in the real world, but it’s certainly better than having one piece of equipment at a ridiculously low volume and having the other pushed all the way up.

<<<I’m not convinced it makes a difference in the real world, but it’s certainly better than having one piece of equipment at a ridiculously low volume and having the other pushed all the way up.>>>

That’s pretty much correct in the real world. People desperately want to reduce the thing to easily remembered rules and it just doesn’t work that way. If you have multiple live microphones, you never want to reduce the master volume control just to bring one loud singer down. But yes, there are far worst things than starting your session with a pleasing balance and all the controls in about the same place.

The overload indicator flashes when the digital signal “goes all ones”–that is, the digital channel runs out of numbers to represent the sound and it creates clipping damage. If the signal clips or runs out of headroom before the analog to digital converter does–or an incoming signal is damaged, the Audacity overload indicator will never light. As far as it’s concerned, there is room for the digital sound channel to get louder.

The illustration for this is the person who plugs a very hot audio signal into the microphone input of their machine. The computer electronics promptly overloads and produces extreme clipping damage, but since the damage happened before the A/D converter, the overload lights will never show.

I suppose you could also get this if the analog to digital converter was damaged so that it never produced that last digital number. 1111 1111 1110 and you never quite got that last ‘1’. No lights.


I might have found the answer to my problem on this wiki page:

More specifically this passage:

clipping indication – this is why we want meters, isn’t it? But is it possible?

  • 4 or more contigouus samples at max (0 dB) is regarded as clipping (“over”) in Red-Book-Audio
  • very special: some soundcards (eg. Soundblaster) cannot record up to 0dB. They limit (non-linear attenuation) the signal at about -4dB to - 2dB, so there should be an adjustable offset for the dB-scale.

It might be possible that my Audigy 2 ZS has this problem.
What is meant with “They limit (non-linear attenuation) the signal at about -4dB to - 2dB, so there should be an adjustable offset for the dB-scale.” ?

Anyone has any advice on how I should determine my record levels so I can record at maximum volume while keeping sound quality (no distortion, etc…)?
Or should i keep my record levels average and amplify the recording afterwards?
I want my recordings to be as perfect as possible.

Any advise / reading material / etc… is welcome!

They stop your signal from getting louder while it’s still analog, before the digital damage point. It’s the digital damage point that turns the lights on.

You need to figure out where that point is.

Grab the lower right point of the Audacity operating window and pull it around in all directions until the audio meters are as large as you can make them. If you make the workspace really narrow, the meters will snap into their own row.

Pay good attention to the zero point while you play something and interntionally overload it. You will find that the meters never go above a certain number, say -3 or -4.

That’s your new overload point. Never let your recorded sound go over that point. If you’re doing live recording, I would leave a good 6dB or so below that. Say the system smashes your sound at -4. Add the 6dB headroom and you should never let your recordings go over -10. If you’re live, you may need even more headroom than 6. Say 10dB headroom added to the 4 gives you a target of -14dB.

If you’re after extreme loudness, there are things you can do with the compressor and limiters inside Audacity Effects. After you get a good recording.


I tried the motherboard integrated soundcard, and the clipping indicators work with this one.
It seems to be a problem with the Audigy 2 ZS card. I tried to record on my brother’s computer with the same card as me (Audigy 2 ZS), and the
clipping indicators don’t work there either. Very strange.

@Kozikowski: where can I find information about making good recordings louder without harming sound quality?

<<<about making good recordings louder without harming sound quality?>>>

You don’t. If you have satisfied the basic requirement of the show being as loud as possible without clipping or pushing the show to “zero” (Normalize can be helpful here) then everything else you do creates damage. You can try applying the Compressor and see if you like what happens. What that does is distorts the relationship between quiet music and loud. Typically, quiet music doesn’t change, but the higher up the volume gets, the less the system lets it increase. Try it on a music selection and push the curves and tool values around to extremes to get an idea what it does and how it works.

This is Effect > Compressor…, not the compression settings in the Export menu. Different compression. One is loudness range compression and the other is digital transmission compression.


The SC4 compressor (a LADSPA plug in) is a much better compressor than the standard one, but more difficult to use.

If you try the SC4, use a very fast attack, a high compression ratio, and a fairly high threshold (probably around about -6dB). Use “Effects > Amplify” after the compressor to bring the compressed audio back up to 0 dB.