Deprecate "real" widget type for Nyquist plug-ins

Two types of slider widgets are available for Nyquist plug-ins;
integer and floating point.

The original widget definition named these as “int” and “real”, though “float” has been supported as an alternative name to “real” since at least version 3 plug-ins (possibly longer).

As the term “floating point” is widely used in the Nyquist documentation, I propose that “float” should be the preferred name and that “real” is deprecated. This will require a few minor updates to our wiki documentation which I am happy to do.

The relevance of doing this now is that I wish to add a new widget type called “float-text” which provides floating point text input (no slider) and it would be best if the naming convention is consistent.