Delayed Startup

Excuse me Please:

I have attempted to search the forum for the term “delayed startup” and not found anything.
I have Ubuntu 14.04, Audacity 2.0.5 and in having placed this into the Startup Applications with the command audacity %F, and frequently Ubuntu/Audacity complains that “another instance is running,….”
There is only ONE(1) instance of Audacity in the Startup Applications window.
I have attempted to use the sleep ##; command ahead of the audacity %F, and all this accomplishes is Audacity NOT launching with login.

May I receive understanding on how to only have ONE instance of Audacity running with Startup/logon?
Thank you kindly for the time taken to respond.

If you are trying to use a file manager or the terminal to import files into new Audacity project windows once Audacity is open, you can’t in Audacity 2.0.5 - you will receive the message you see.

If that is the problem, uninstall the Audacity 2.0.5 version you have now and install the unofficial 2.1.1 “Panda Jim” PPA from

Otherwise, just be patient and wait for Audacity to launch rather than execute it multiple times.


Thank you kindly for the response.
I apologize if I was unclear.
This intermittent issue occurs, seemingly 2-3 out of 6 times, with system reboots/restarts.
(this system needs to work flawlessly as neophytic users will be using it too)
It logs in automatically, with only ONE instance of Audacity in the Startup Applications list.
Yet at the time the error of “multiple instances…” is presented, there are no other instance of Audacity running.
Attempting to manually launch it results in the same error, even though Audacity is not listed in System Monitor, which forces one to reboot the PC.

Placing a “sleep 30;” command in the Edit of Startup Applications for Audacity seems to prevent Audacity from automatically launching at all. :cry:

does this make the issue more clear?

Thank you. I thought perhaps you were trying to manually execute Audacity after it had already launched automatically. That will cause the error you see. Audacity won’t allow more than one instance of itself, so the second instance is prevented from launching.

Can you try without the %F in the startup command? If Audacity is properly installed then the command only needs to be “audacity” (without the quotes) as far as I know. Or you can enter the path such as “/usr/bin/audacity” (without quotes).

If Audacity still tries to launch multiple times, uninstall 2.0.5 then try that 2.1.1 PPA instead. The current 2.1.2-alpha launches once only for me with a “/usr/local/bin/audacity” startup command (/usr/local/bin is where I installed my self-built Audacity).

Even if the intermittent double launch in 2.0.5 is an Audacity bug (as opposed to an Ubuntu bug), we can’t fix obsolete versions of Audacity, only our current code.


Thank you kindly for the input.
I removed the sleep and % aspects of the command, and rebooted a few times, on time 3, the “Audacity is Already Running” error came up,…

I did, previous to your post and the above test, follow the process detailed for installing PPA and having the Software Updater bring Audacity to 2.1.1; so the “Already Running” error seems to affect both 2.0.5 and 2.1.1…

and is still intermittent,… :cry:

why would audacity trip over itself while it is being launched to try and launch itself again?
and somehow leave enough of something in memory to reject manual launches after the error,…

Did you uninstall Audacity 2.0.5 using “Ubuntu Software Centre” before installing 2.1.1?

I recommend you ensure in “Ubuntu Software Centre” that no Audacity is installed.

Then open the Terminal and run

sudo apt-get install ppa-purge

sudo ppa-purge ppa:ubuntuhandbook1/audacity

to make sure nothing of the PPA is left behind.

Then reinstall the PPA.

Then add nothing else except “audacity” (without quotes) or the path to the 2.1.1 audacity binary to the startup command.

If the problem persists I recommend you report the behaviour to Ubuntu and see if they can offer any explanation. I have rebooted six times on Ubuntu 14.04 (Unity Desktop) with 2.1.2-alpha as a startup application and there is no error message. In other words, it does not seem to happen with our current code, which is all that we can change.

You can try 2.1.2 when it is released. Panda Jim might make a release or you can compile Audacity from the 2.1.2 source tarball when released.


to answer your Q,…
no, why should I uninstall something that has been upgraded?
2.0.5 no longer exists on the PC, it is now 2.1.1

but I went through the software center and Removed Audacity, and input your recommended commands from a root terminal.
I removed the -purge and reissued the command, but the OS complained about it could not find a package,…
So … my understanding is failing me, I am not installing Audacity, but PPA?
thought PPA was some accessory something needed to be able to have the Software updater update Audacity,…

Because uninstalling the system package before installing the PPA is the best approach so you don’t have possible conflicts with duplicated plugins or other files. That’s why I said you should do that.

You should run the commands as I gave them, to be sure nothing of Audacity is left behind.

When you have run the commands as I gave them and it returns that there is nothing to purge, then you can go ahead and install the 2.1.1 PPA again. All we are doing is making sure that no installation conflicts are involved.

I doubt it matters, but are you using Unity, or Gnome, or some other desktop?


{prevented from posting by your response, so will answer too}
{I think this has some variant of Gnome on it (I forget what it is called), as the original UI “Unity” was too much like M$win8+

well,… I removed everything, found 2.1.1 and reinstalled it via CLI (, rebooted a few times, and on the 2nd or third reboot, the same error. :angry:
again; there is only ONE instance in the Startup Applications list.
not two or more,…

is there a log or something that would detail what the OS and or Audacity is doing to precipitate this error?
this way it can be determined if the OS or the application are confused, and potentially devise a work around.
which speaking of workarounds, I still question why the sleep 30; addition to the command had the exact opposite effect.

any assistance in understanding and further troubleshooting would be greatly appreciated…

I have tried four times with GNOME flashback and there is no problem. But we cannot guess what you have - you have to say precisely.

OK, so we can eliminate duplicated installation files as a cause. That was important to do.

There is only one instance in mine, and I do not see the problem.

You could perhaps replace your current startup command with a command for the terminal to execute Audacity, then look at the messages in the terminal. Perhaps that might even solve the problem, depending what the problem is.

The best method though is to compile Audacity HEAD and see if the problem occurs there. HEAD is stable at the moment as it is being prepared for release.

If the problem occurs (on your system) in 2.1.1 but not in 2.1.2, then there is nothing for us to fix. To reiterate, we cannot go back and modify previous versions of Audacity.