Delayed echo on vocal overdub

I’m recording an overdub track with music behind it and when I record, there’s a delay between my voice hitting the mic and it being played back in my ear.

I’ve done everything I’ve seen to do online, including

-turning off “listen to this device” in settings
-turning off monitoring
-turning off software playthrough(issues with this one below)

I’ve uninstalled and reinstalled audacity, I’ve changed the cables I’m using, I’ve tested the mic without the backing track (it has the same issue) and I’ve tried the mic with different software (it doesn’t have the issue then).

The only fix I’ve seen I’ve been unable to make work is turning software playthrough off. When I turn software playthrough off and hit record, it generates a buzzing, hissing sound in my headphones, the needle on the track doesn’t even move, so it’s not even creating a recording, and the bar in the lower right of my screen with the clock, data, display that I have a mic connected, etc., glitches like crazy and flashes back and forth between two sets of different symbols.

I’d really like to get this working and as far as I can tell I’m the only person who has had this issue and posted about it. Anyone think they can help?

Are you sure that happens when Software Playthrough is “off”? I’d have though that would be more likely when Software Playthrough is “on” :confused:

What about your hardware? Make / model of sound card / headphones / microphones and how they are connected?

Hey Steve,

Yeah, the glitch is definitely happening when software playthrough is off. That’s why I was confused. All the similar questions and answers seem to indicate the opposite would be the problem.

I just tried to do a test and got hit with this notification

“Error opening recording device
Error Code: -9992 insufficient memory”

For the hardware - I did some digging and I think my audio driver that came with the computer (HP Laptop 15-af008ns, just bought last December) is the Intel(R) Display Audio and/or Realtek(R) Audio. I also have two drivers for a pair of wireless headphones I paired. Finally, I’m using a Yeti Nano for both input and output when I’m recording. It’s a simple USB mic.

If you are using Windows 10 you may need to update the computer’s drivers:

I bet I can do some of this.

For perfect overdubbing (you hear a perfect theatrical mix between the backing track and your voice) you should plug your wired headphones into the Nano. No option. Any live voice coming from the computer is going to be “one computer late” and have an echo.

Your wireless pairing is sending your live voice to you over the wireless link with a computer delay. When you turn on Audacity playthrough, it’s being sent twice and one of them is out of phase or has some other bucking relationship. That accounts for turning playthrough on and having your voice vanish.

Wireless headphones are insanely handy, and that’s the only advantage. Great for listing to your Grateful Dead collection while you paint the walls in the family room. For production, they’re not a gift from the angels.


Hi Koz,

Whole new issue. Now I can’t even record. I’ve got Audacity recognizing my Nano win both input and output, live monitoring is off, overdub is on, software playthrough is off, it’s set to 48000 kHz, I’ve uninstalled and reinstalled it, and when I hit record I get "“Error opening recording device
Error Code: -9992 insufficient memory”

I had this issue before with software playtrough on, but now I just can’t record anything.

It’s at the point where I might have to reset my computer to factory default settings to try and get this to work.