I have activated the playthrough feature on audacity but the 1/2 second delay makes it very difficult to play and record my keyboard. Is there any way to avoid this delay?

Monitor directly in hardware, not use software playthrough which is delayed because it has to route through the computer from input to output. Hardware playthrough usually means connecting your headphones to some USB mics that have a headphones port, or to an appropriate USB recording interface.

If you are using the built-in sound device, on a few high end laptops or older desktops you may be able to go the playback side of the Windows control panel for sound and unmute the external mic input. That will also give you playthrough without latency. If you need help with that, please answer the questions in the pink panel at the top of the page.

More information is at and


I am using Audacity 2.06

You will get latency with software playthrough whether Audacity performs the playthrough or whether you make Windows perform it by setting “Listen to this device” (on Windows Vista or later).

It makes no difference what Audacity version you are using, but I suggest you look closely at Help > About Audacity… . You should see “2.0.6” with two dots (periods) in the version number. If you see “2.06” you have an unofficial Audacity not made by us, in which case I suggest you uninstall that version and obtain Audacity here: Audacity ® | Download for Windows.

If you need help setting hardware playthrough or deciding what equipment to buy, please tell us what version of Windows you have and tell us makes and model numbers of the microphone and/or recording equipment you have now. Also tell us how you connect that equipment to your computer.