delay while recording

I’m a complete newbie, using Windows 10
Line 6 Helix USB interface

I’m attempting to record guitar lead over a backing track.

I’ve opened the Backing track in Audacity, then try to record a new track.
Overdub is on.
Playthrough is off.

When I start recording, there is a significant (half a second) delay from picking a note, to what is heard coming through the software while I’m playing. The interesting thing is that when I play back what I’ve recorded, everything lines right up with no delay.

How do I listen to the backing track but turn off monitoring what’s being recorded. I can listen to the guitar through a monitor out of the Helix.

Thanks in advance for the help.

In the Windows Sound control panel, ensure that “listen to this device” is NOT selected (not enabled) for any recording devices.

Where are your headphones plugged in?

Thanks for the quick reply.

I’m actually not listening on Headphones. I have the computer plugged into a Mixer, and sound coming out of Monitors. The sound for my guitar is coming from the Amp speaker from the Line 6, which while playing is correct timing… Just need it not to come out of the computer.

That fixed my problem. Thanks