Delay during recording

Could anybody advice me pls? When I start record my guitartrack I can hear the signal from my guitar delayed. I can´t find how to turn this dealy off. Thank you!

It is probably caused by having “software playthrough” selected in “Edit > Preferences > Audio I/O”.

Maybe you are right but when I choose “software playthrough” off, I can´t hear what my guitar playes. Could be solution not to connect guitar straight to the computer but at first to the amplifier and from amplifier to the comp?

Thank you

There are several ways to do it, and that is one of them.

If you are using a conventional sound card, then another way to do it is to use the sound cards mixer application (Windows Mixer) to play the input channel. (If you are recording into the sound card “Line in” socket, then make sure that this input is enabled for playback and not muted).

Another way (and for electric guitars this is the way I prefer), is to record the guitar cab with a microphone.

Depending on what equipment you have available, there may be other ways to set it all up (for example monitoring directly from a mixing desk).

It is very kind from you, thank´s!