Default mp3 tags not saved issue

I seem to have a similar issue when installing audacity fresh on a new machine to this

Basically when I try set the tags defaults on the export mp3 dialog, the defaults dont actually persis till the next time I use the application.
I worked out that if you change the bitrate to something other than the default, and then advance to export, and save the defaults, that it starts saving the tag defaults.

Hope this helps the next person.

Belay that
For some reason, the default tags are empty again today. Would love if someone can confirm that this is a behaviour regression.
It does not happen on my other computer which is running an older version among other differences.

Tried with some variation, still no joy. But does this mean that I need to script the Tag adding to save me the mouse clicks to load the defaults each time?
I dont think it’s a regression, i think the issue is the source files are zoom recording as .m4a have some effect - does that help?

Even if the default tags are set, if you import a file into a new Audacity project and the file contains metadata tags, the file’s tags will override the defaults.

To avoid overriding the defaults, save your defaults as a template, then load the template after importing the file.

Thanks, yeah that did get my workflow working again.