Default jamlab caused my computer to blue screen??

hey all,

i recently tried setting up my m-audio jamlab device on a Windows 10 Pro 32bit computer- when i plugged in the jamlab, may computer blue screened and restarted, the error was ‘whea_uncorrectable_error’. i unplugged the jamlab and powered on, same result.

long story short, i have reset my BIOS to default settings and completely low level formatted my hard drive and tried to reinstall Windows- same error. so i’m starting to wonder if something happened to the computer hardware.

i looked into the ‘whea’ error and it’s most commonly associated with hardware problems (CPU voltage spike, memory issues etc) or problematic Windows updates.

has anyone else run into this issue with the jamlab? i used it for years on my last computer and had no issues with it, and the current computer has been working fine until i plugged the jamlab in- i’ve never seen a computer blue screen from plugging in a USB device, but i guess anything is possible…

many thanks for any ideas/suggestions!

The Jamlab is a discontinued product. The last driver, released in 2011, supports the Jamlab up to Windows 7:

Moved to the Windows board as this is Windows-specific.