Debugging error opening slightly older .aup files.

I guess this is my first posting in the hopes of getting a quick response to this unexpected problem. A friend just upgraded my Windows 7 computer to Windows 10 Home (Version 1903). He recommended that I use an SSD as my main drive, while my old hard drive still resides in this desktop computer, as an extra backup. It still contains all my old files as is, including many Audacity projects. Of course tonight I just installed Audacity 2.3.2 just fine, but when I try to open my older .aup projects from my hard drive, I am getting this wxWidgets Debug Alert. Looks like another forum member posted an almost identical case, but it is the way his was written that slightly differs from mine. I don’t yet know how to attach screen shots as he did, but I will copy exactly what the message reads:

wxWidgets Debug Alert
X A debugging check in this application has failed.
c:/wxwidgets-3.1.1\src\common\file.cpp(475): assert "IsOpened()"failed in wxFile::Length().


Hopefully a good sumaritan will respond with an easy fix because I have quite a bit of these audacity projects recorded on both my hard drive, and other USB flash drives.

It’s just a failed debug check - it does no harm - just click the OK and carry on with Audacity.

Also click the “Don’t show this again” - and you won’t see it again :sunglasses:

This is a known bug - we have not been able to fix it so far - but the workaround above is fine.


Is it? Do you have a bug number? (It’s a different assert failure than the bug that came to my mind).

I would also suggest that you try that. Let us know what happens.

Also, does this happen with new projects?
Does this happen with all of your old projects, or only some?

Actually you’re right Steve - it’s not either of the two “Windows: wxwidgets 3.1.1 debug failure message” ones that we have logged:

20174 occurs when a user has FFmpeg 0.6.2 installed (for Audacity 2.0.5 and earlier) and then installs FFmpeg 2.2.2 alongside it in the same folder.

@DJ_Andy4Aup2Day: when upgrading your computer W7 to W10, did your friend also upgrade FFmpeg like this ? Or did you reinstall FFmpeg when upgrading to 2.3.2 ?



First of all - thank you so very much for responding as I was beginning to get very worried as I depend on Audacity a lot. I think we are getting somewhere, but not quite yet. Now (Mr. waxycylinder) as far as your response is concerned on being a known bug and clicking [OK] to move on, its not working !! There is no [OK] option to choose from and move on at that point. On that screen, I only see a [STOP] and a [CONTINUE] option. If I hit [STOP], I get to another screen that reads it is going to generate some ‘debug error’ report to Audacity, and apologizes for the inconvenience. From there I can either choose [OK] or [CANCEL]. If I hit [OK}, it supposedly generates some file or something in a designated path under my Aucacity files in my computer. From there - the whole Audacity application goes away or erases from my screen, and I am back in my regular Windows environment.

Now If I hit [CONTINUE], the same ‘debug error message’ appears all over again. Now it is when I hit [CONTINUE] one more time that the whole Audacity window disappears - and I am back into my regular Windows screen once again. But regardless of what you do, Audacity is disappearing at this point. You can always start it again - you know.

Now as far as what Mr. Steve asked, it is not happening with new projects. Today I had another worrisome experience when I got another error while trying to record an audio clip from a portable digital recorder connected to the microphone jack on my computer. It somehow did not recognize the recording source - or something !! But it mysteriously disappeared and it looks like I was able to record and save my first Audacity project on this Windows 10 environment. So at least that is working fine, but I am still having trouble loading up these Audacity recordings saved on my Windows 7 environment, with the same Widgets debug error message I was telling you about.

Now there is something else that is worth mentioning is that I was able to load up .wav audio clips recorded from my Windows 7 environment just fine. I got no error. Now I have heard that these can be converted to .aup projects as well. But it will take a ‘heck’ of a time to do this since there is so many .aup projects that I will have to convert to .wav, and then back to .aup for this newer Windows 10.

As far as your last quote (Mr. waxycylinder), the guy who upgraded both my computers probably knows nothing about Audacity since it was not installed when he finished the work. He has his own business and charged $100.00 per computer. I downloaded the latest version of Audacity myself and it was able to install it myself. It is when I tried to load up these slightly older recordings that I began to have problems. Now regarding that FFmpeg that you mentioned, I do remember that I installed that feature or upgrade for Audacity before when I was working under Windows 7. I think (don’t really remember), that I needed to add this clip in order to convert my .aup projects to MP3. I did check my hard drive and it is there installed alright. But it is not on this Windows 10 environment. Do you think this is the feature that is missing - that is causing all my problems ?? I can always install it.

Look. I know I write a lot but I needed to convey as much as possible to give you all a clue what I may be experiencing, and lets see what we can do in order to proceed and hopefully eliminate this Widgets debug error which has me very worried. Hopefully you guys can help and get me out of this tech nightmare.

Guys - I have an update.

An update on this most bizarre and unusual circumstance why the Audacity projects on my hard drive are not loading - giving me this Widgets Debug error. Well I decided to download and install Audacity on my laptop as well. This again - is a Toshiba Satellite A500 which of course, is going to use the audio program too. It installed just fine. Now this laptop again, was upgraded to Windows 10 from 7. The internal hard drive was removed and replaced with a recommended SSD drive, presumably because it last longer and the reboots are faster. And yes - they are !! Anyway, I decided to plug in a 16GB USB flashdrive which has a number of Audacity audio projects as well. To my astonishment, they loaded just fine. Wow !! Now I decided to plug in the same USB drive to my desktop. To my astonishment, the same .aup project files loaded up as well. Oh my god !! But why aren’t the .aup projects recorded the hard drive of my desktop not loading ?? The Audacity projects recorded on this USB memory drive were done with the same Audacity program installed in my desktop computer which was using Windows 7, which created the .aup files I cannot access ?? Why am I getting this Widgets debugging message ??

The answer may lie in the fact that there may be administrative obstacles in my desktop. You see - it still has the old hard drive there where I can see and access all of my files. But I need those Audacity audio files and I can’t load them with this 2.3.2 version. What I tried to do tonight was to copy the exact files to the SSD directory on my desktop, which Audacity 2.3.2 is installed. Audacity is made up of a main control .aup file, followed by a set of directories and sub-directories which contain all these mini files that make up an audio project. The longer the audio clip, the more directories there exists. I decided to pick a small one with only one sub-directory. Since this newly installed SSD on my desktop is my main drive, I copied the main .aup file for this audio clip. I then tried to copy the corresponding directories associate for this .aup project and the system gave me a message that I needed ‘Administrative Permissions’ to accomplish this task. I was confused. Supposedly I am the administrator for this desktop. Why am I getting this message ??

What I decided to do next was to create an identical directory and sub-directory in my main SSD drive, and copy the corresponding mini-files in a batch format to see if that would work. I wanted to know if this .aup project was already in my SSD drive, would it [OPEN] so I can hear it. But I got the same error message. I need administrative permission to accomplish the task. Now I think it may let you copy one file at a time, with this message obstacle appearing every time. But with so many files, this can get frustrating. But this all leads me to conclude that the Audacity program needs that main .aup file, and all of its its mini files in the corresponding directories. Could this administrative obstacle be causing this Widgets Debug Error to appear ??

I still do not know too much about how these administrative limits work on my computer, even though I am understood to be the administrator. But I can contact the guy who upgraded both of these computers to give me an answer as to why it is not letting me copy entire files in one batch at a time. But in the mean time, I will allow you guys to analyze all this and get back to me with your expertise.

Oh - and a message to waxcylinder. When you told me to put an ‘X’ on that ‘Do Not Show This Message Again’, it would not work. I keep getting the same message all over again. Thereafter - Audacity disappears from the screen before you have to load it up again.

The internal hard drive was removed and replaced with a recommended SSD drive, presumably because it last longer and the reboots are faster. And yes - they are !!

One of the Sys Ops at work and I had almost the same laptop computer. I had the SSD and he had the spinning metal drive. I had to do a task on his machine and I thought it was broken. Sluggish and slow responding. “No,” he said. “That’s just about normal.”

reboots are faster.

Do you have to reboot your machine very often?

Supposedly I am the administrator for this desktop

Yes, but you didn’t boot into the administrator’s account. You have two of them on this machine. I think you smacked into a Windows Security issue.

This doesn’t happen very often, so I don’t know the spells to get out or manage it. I’m pretty sure you can’t just take a Windows System drive into another computer and magically open up all the work.

I will also bet you can make a couple of changes and boot from the old drive. That may let you open and copy all the old work.