Debug report being generated when importing wav file

I’m running Audacity 2.2.2 on a corporate device. We have Windows 10 Enterprise, 20H2, OS Build 19042.985 and I have FFmpeg 2.2.2
I can normally import wav files with no problem. A user contacted me yesterday saying they were getting the ffmpeg error when importing that file. When I tried the same file, same issue. Uninstall and reinstall Audacity and ffmpeg and now I get debug report and crash. I’ve attached the debug zip. We have somewhere around 900 downloads of Audacity and I’m hoping this is a one off on the file. (104 KB)

Audacity 2.2.2 is a very old version. I doubt that many of the experienced users here are running such an old version.

The most recent Audacity 2.x version was Audacity 2.4.2 (released Jun 2020 ).
The current version is Audacity 3.0.3 (released 26 Jul 2021)

If it’s just that one file that’s causing the problem, then that’s a strong indication that the file is malformed in some way. Would it be possible for you to share that file with us so that we can investigate the issue?

That’s confirmed by the log that you posted:

07:39:13: File name is C:\<redacted>\<filename>.wav
07:39:13: Mime type is *
07:39:13: Opening with libsndfile
07:39:13: Opening with libav

That shows that Audacity attempted to import the “wav” file with libsndfile (the native importer for WAV files), but that failed, so Audacity passed the file to libav (part of FFmpeg) so that FFmpeg could have a go, but that also failed. A properly formed WAV file would open with libsndfile.

The actual recording is consumer information, so I can’t share that. It came from Qfinity. We’ve done a bunch of internal testing and found a work-around using a different file format export (wma) from Qfinity.

Thank you all for your help as I can reply to our software team and the end user.

As to the version of Audacity, I get it. Every time I try to add a newer version to our App Store, I have issues with it working with Windows 10 20H2 and the ability to recognize my Shure mic and H4 Zoom processor. I would love to upgrade the enterprise but I have a ton of users who use older versions successfully.

On the plus side, we LOVE Audacity and our moving more and more people to it so we’re growing the base.

Thanks all for your help on this.

As part of this ongoing saga, we discovered that .wav’s coming out of Qfinity were corrupted. We have IT people working on it, but another issue that has come up is the FFmpeg doesn’t appear to be able to import stereo g729 which Qfinity seems to export at times. Why we get stereo instead of mono sometimes is a whole other story. We’re in the process of upgrading to the 64 bit version to go with 3.1 but I tried it and it didn’t work.

Any suggestions?