cursor won't move with Blue Snowball

Just got a new Dell Inspiron Laptop, first thing I did was download Audacity 2.0.5. Records with built in mike, but when I select my Blue Snowball the cursor won’t move. Looks like it is trying to move–jiggles a little, but doesn’t go anywhere. After I press stop I get an info box: Latency Correction setting has caused the recorded audio to be hidden before zero. Audacity has brought it back to start at zero.

I tried changing the latency to 0, and I no longer got the error, but the cursor still doesn’t move.

Change that back. It will make things worse rather than better.

The default settings are:

“Edit > Preferences > Recording”
Audio to buffer: 100
Latency correction: -130

“Edit > Preferences > Quality”
Default sample rate: 44100
Default sample format: 32 bit float

Note the “minus” sign in the Latency correction value.

Open the Windows Sound Control Panel and check that the Blue Snowball is working correctly, You should see the green bars moving when you talk.

If that is working correctly, open Audacity (if Audacity is already open, close it and relaunch Audacity).
Ensure that the recording input in the device toolbar is set to the USB microphone, the output device set to your normal sound card. and the number of channels set to “1 (mono)”.

Look in the Transport menu and ensure that “Software Playthrough” is disabled (not selected).

Click on the Recording meter to activate it and you should see the red meter level respond as you talk.

If all OK to this point, press the Record button and Audacity should start recording.

Thanks! I didn’t change anything (had already set the latency back to default), just checked everything like you said and it worked.