Cross Platform Editor Not Responding

Windows 10/3.1.3
Many attempts to import MP3 files. Once imported, transport will not play and a window stating "Cross Platform Editor not Responding. I have tried reinstalling Audacity but that does not fix the problem. ???

Did you get Audacity from here?

Windows installer has a selection to make sure it really does start over and not leave settings and preferences behind by accident.

Can you play this MP3?


I’m having a very similar issue – and it only started this am.

Uploaded my file - no issue.

mixed track - no issue.

Tried to edit – Blue Circle of death - not responding, page goes white.

Tried it with several audio files, all of which I’ve used audacity in the past with no issue - suddenly I cannot edit them either, same thing as above happens, doesn’t respond, blue circle of death, white page. ETc. So I uninstall, reinstall latest version - same thing.

I’ve been using audacity for years, heck, I used it yesterday, no issue, suddenly this am, problems. Checked my computer, updates are good, no problems there, just cant figure out for the life of me what the problem is.

any guidance is welcome. Thank You.

Koz, thanks for your response. Yes, I can play the mp3 but after it’s imported and I try to play it the above happens. I am travelling now but when I return home I post an attachment.

Here are some screenshots of what I am seeing. Help me if you can. Thanks
Screenshot (302).png
Screenshot (300).png
Screenshot (299).png
Screenshot (298).png