creative soundblaster card problem

I am running Vista Home Edition 32 bit and Audacity 2.0.3 and it was installed from an exe. I have been copying cassettes from a tape deck using an ADS RDX-150 interface box for quite some time. I installed a Creative Sound Audigy SE card and am no longer able to do so.

The tape deck uses stereo cables from the tape deck and a USB cable to go into a USB port on the PC. The unit appears to be working-at least the lights blink and turn green when it functions. I moved the cable to another USB port-same result.

The Audacity settings are
1)Audio host-mme
2)the input device - Microsoft Sound Mapper

  • I don’t believe they changed after I installed the card but I haven’t looked at them in such a long time, I could be wrong, but I’m pretty sure I’m not.
  1. the other audio host is windows direct sound
  2. the other input devices are:
    digital input device
    line in(audigy)
    I tried all of these and only the mic worked.

The card seems to work, at least the speaker and microphone work.

Under Device Manager, I see
high definition audio device
high definition audio device
sb audigy
usb audio codec
they all show as functioning

under control panel/sounds/recording I have
2 mics and a line (all 3 not plugged in)
digital input device-spdif(working)
microphone audigy(working)
line-in audigy- unavailable
auxiliary audigy- unavailable
s/pdif in audigy - unavailable
microphone usb working

any ideas?

I forgot to mention that I installed the most recent drivers for the card(Oct 2012). Also, the Audigy card was not a replacement for an existing PCI card-the sound card was the onboard card. I just got this message from Creative
“First you have two different devices, one is the PCI soundcard while the other is of USB type. If both devices are running on one PC, I am afraid it’s not possible. Operating system will only allow you to utilize one type of audio device for playback and recording. You can use alone tthe RDX-150 without any additional audio device.”
I asked for a clarification in case he’s thinking the RDX is an external sound card.

Thanks for all the detail, that is really helpful.

To clarify a couple of points:

  1. The “Creative Sound Audigy SE card”: This is a PCI sound card (not USB)?

Where exactly are the stereo cables from the tape deck going to?
Where is the USB cable coming from?
(the make and model number of the tape deck may also be useful information)

You posted while I was typing :wink:

The only RDX-150 that I see on-line is a USB sound card :confused:

A “USB cable” implies that somewhere embedded in that recording chain is a forrm of soundcard an ADC (Analog to Digital Converter). The USB “cable” is trying to pass an already digitized signal to your PC totally bypassing your newly installed sound card.

  1. If you want to continue with the USB connection then you nneed to ste the input devive to be the USB Audio Codec (but make sure you set the the output to your soundcard or you won’t be able to hear anything. The USB device should be plugged in before you start Audacity.

  2. Alternatively if you want to use your new soundacrd for the ADC conversion then the tape needs to be plugged directly to the PC’s Line-in mini-jack port (assuming that you have one - modern laptops mostly don’t, hence the need for USB soundcards) - or there may be a line-in port on your souncard. Do not use the Mic-in on the PC as this will overload - a line-level signal is significantly stronger than the minimal level thata mic-in expects.


Here’s a link to some info on the ADS rdx-150:
just to make sure the box was working I disabled the sound card in device manager and tested it with audacity and it recorded fine so there must be an issue with the card. I will try both suggestions you mentioned.

forgot these clarifications.
the card is a PCI card
the cables go from the tape deck to the RDX and the USB cable goes from the box to a USB port

I tried the 1st suggestion. The USB Audio Codec does not show up in the list of recording devices. It DOES show in device manager as enabled. But in Vista/control panel/sounds/manage audio devices/recording, it does NOT show up
I have to get a cable to try #2. but it sounds like an alternative

In what way? Are you saying if you right-click over the speaker icon by the system clock, then choose “Recording Devices”, the USB interface is not listed?

Have you tried “Detecting USB and Firewire devices” here ?

Is that “microphone (usb)” a real usb microphone?

What happens in Audacity for the devices that “don’t work” ? “Error opening sound device”?

Operating system will only allow you to utilize one type of audio device for playback and recording. You can use alone tthe RDX-150 without any additional audio device."

Perhaps he means Creative can’t cope with the USB device?


That is a USB “sound card”. I know that it does not look like a “card”, but in effect that is what it is. Probably more accurate to describe it as a USB audio I/O device.

Ensure that the device is connected to the computer (and recognised by Windows) before you open Audacity. It should then appear in the Device Toolbar as a USB recording input. (It may appear as a USB “mic” or some other sort of USB device - that depends on what the USB chip in it is and how Windows identifies that chip).

The USB mic option worked! I could have sworn I had tested it earlier(see a previous reply)-another senior moment. And I don’t remember selecting that option when I used Audacity with the onboard sound card. But I guess after recording several dozen tapes, I wasn’t paying attention.

Thanks for your help!


Glad we got you sorted Ron :slight_smile: