Crashes every time I try to record

Bug? For the first time ever, when I tried to record two tracks I got a message (first time ever) asking me if I wanted Mac to access microphone. I said yes, although I do not need it yet. Now every time I hit record it creates a new audio track that is recording audio. There is no way to turn it off. (I turned it off in Mac settings but it does nothing). Then it crashes; every time.

  1. Accessing the microphone. That’s macOS asking you if you want to grant permission to Audacity to access the “microphone” (Apple’s catch-all term for any audio input device).

  2. In Audacity > Preferences > Recording there is a checkbox for “Record on a new track”. Uncheck that.

  3. If you turned off microphone access in the Mac Privacy & Security Settings that may be why Audacity is crashing.

– Bill

Thanks so much Bill for the rapid reply. I ended up downloading the new version and it got rid of the problem. But now I know what to do if it happens again. (In the new version when it asked me if I want Mac to access the mic, this time I said no and it solved the problem.

That’s not Audacity asking to access the “microphone”, that’s macOS. How can you record anything if Audacity is not allowed access to any audio input devices?
– Bill

This topic was automatically closed after 30 days. New replies are no longer allowed.