Crash when using "Manage" for effects etc. (2.1.1)

Anytime I try to find vst’s and such or manage my plugins from the Effect->Manage or Analyze->Manage or, anywhere else I see a *->Manage, Audacity crashes and brings up a debug report window. This also happens when using Help->Generate Support Data, which thanks to a dry sense of humor is rather amusing.

Any ideas?

Windows 7 Ultimate 64-Bit
Used the EXE installer and tried uninstalling reinstalling once so far.

9:47:04 AM: Audacity 2.1.1
9:47:04 AM: Trying to load FFmpeg libraries...
9:47:04 AM: Trying to load FFmpeg libraries from default path, 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
9:47:04 AM: Looking up PATH environment variable...
9:47:04 AM: PATH = 'C:\ProgramData\Oracle\Java\javapath;C:\Python27\;C:\Python27\Scripts;c:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Broadcom\Broadcom 802.11 Network Adapter'
9:47:04 AM: Checking that 'C:\Program Files (x86)\FFmpeg for Audacity' is in PATH...
9:47:04 AM: Warning: FFmpeg directory 'C:\Program Files (x86)\FFmpeg for Audacity' is not in PATH.
9:47:04 AM: Temporarily prepending ';C:\Program Files (x86)\FFmpeg for Audacity' to PATH...
9:47:04 AM: Checking for monolithic avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
9:47:04 AM: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: the specified procedure could not be found.)
9:47:04 AM: Error: Couldn't find symbol 'avcodec_version' in a dynamic library (error 127: the specified procedure could not be found.)
9:47:04 AM: avformat not monolithic
9:47:04 AM: Loading avutil from 'avutil-52.dll'.
9:47:04 AM: Loading avcodec from 'avcodec-55.dll'.
9:47:04 AM: Loading avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
9:47:04 AM: Returning PATH to previous setting...
9:47:04 AM: Actual avutil path C:\Program Files (x86)\FFmpeg for Audacity\avutil-52.dll
9:47:04 AM: Actual avcodec path C:\Program Files (x86)\FFmpeg for Audacity\avcodec-55.dll
9:47:04 AM: Actual avformat path C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll
9:47:04 AM: Importing symbols...
9:47:04 AM: All symbols loaded successfully. Initializing the library.
9:47:04 AM: Retrieving FFmpeg library version numbers:
9:47:04 AM:    AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
9:47:04 AM:    AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
9:47:04 AM:    AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
9:47:04 AM: FFmpeg libraries loaded successfully.
9:47:24 AM: Error: Failed to copy the file 'C:\Users\Jesse\AppData\Roaming\Audacity\pluginregistry.cfg' to 'C:\Users\Jesse\AppData\Local\Temp\Audacity_dbgrpt-6472-20151229T094722\pluginregistry.cfg' (error 2: the system cannot find the file specified.)

Used the EXE installer and tried uninstalling reinstalling once so far.

Reinstalling doesn’t reset Audacity. To make Audacity start from zero, you have to reset preferences with an option part-way through the install.


Resetting preferences no longer resets your enabled plugins. One of those plugins is probably the problem. The 1.7.1 “Queen Mary” VAMP plugins cause what you are experiencing. If you have those plugins, uninstall them then replace them with the 1.7 plug-ins.

If you are still stuck, open Explorer, type:


into the Explorer address bar then press ENTER on your keyboard. Open the “Audacity” folder then attach the “pluginregistry.cfg” file. Please see here for how to attach files:


Resetting preferences no longer resets your enabled plugins.

So no more lifeboat.
How do you make Audacity start from dead zero?


hmmmm, I don’t have a pluginregistry.cfg

I use Sonic Visualiser for analysis, so I’d prefer not to have to alter my VAMP plugins as they work fine in SV.

In that case you will need them to be disabled in Audacity.

Did you find the folder: *Users<user name>\AppData\Roaming\Audacity* ?
What files are in there?

Quickest way is to delete the three files: audacity.cfg, pluginregistry.cfg, plugins.cfg and pluginsettings.cfg from %APPDATA%\Audacity.

Yes it would be much more user friendly to have a “reset” for plug-ins, but the obvious place to put a reset button is in the Effect Manager interface, which would not help at all in this case because Audacity crashes when opening the Effect Manager.

If there was never a pluginregistry.cfg file before, Audacity does not get as far as to create one before the crash.

So there is no way to tell Audacity the plugins are not to be enabled.

Unless Sonic Visualiser can specify where to look for VAMP plugins (Sonic Visualiser 2.4.1 which I have doesn’t seem to let you specify), then the only easy way I can see to prevent the Audacity crash will be to rename the location where you have the plugins when you want to use Audacity.


Alrighty, renaming my VAMP plugin directory allows the Manager in Audacity to function properly. I suppose I’ll downgrade my Queen Mary plugins as per Gale’s initial suggestion and see if that solves the problem without requiring the renaming.

All help regarding this matter has been much appreciated. I’ll post back here if the downgrade works or fails, otherwise, I consider this problem solved.

My first experience here with the Audacity Forum has been a good one, so thank you all for your help.

Just switched from the 1.7.1 to the 1.7 “Queen Mary” plugin set and all is well. So I’ll just stick with these. Again, the help has been much appreciated.

Thanks for the feedback.