Crash when applying Eq

i’m having a problem the draw eq (not even the curve version). I like to duplicate tracks multiple times and use the eq to isolate certain areas of the spectrum so I can make my 2 track recordings easier to edit for sound (as if they were multitracks). the problem started when I updated to Audacity version 2.2.2 on Windows 10 after my old laptop died. I try to shelve off a good deal of the sound and it does what I filmed in this video.

please forgive the music coming from my headphones. that’s not even me. :smiley:

I hope I posted this in the right place. thanks

I’ve moved your post to a new topic, which is better than trying to discus multiple issues in one topic thread.

The current version for Windows is 2.3.0. It is available via the Audacity website: Audacity ® | Download for Windows
Try updating to the current version.

thanks. while I was waiting for your reply I pressed the file into a wav and uploaded it into a new Aud project. then I tried slightly different eq settings and it worked. will be updating to 2.3.0 shortly.

Just a “heads up”, Audacity 2.3.1 is due to be released in February. It is still worth updating to 2.3.0 in the meantime.

finally had another couple of crashes while applying the eq again so I finally installed v 2.3.0 (i’m a procrastinator :stuck_out_tongue: ) and it happened again. :open_mouth: :astonished: :smiley:

Did it happen with one of your saved projects (that you had problems with previously), or was this a completely new project?
Were you using an EQ preset? If so, which one?
Are you able to reproduce the crash at will?

yes, it was a saved project. I don’t use presets, just the default eq that comes up when you hit the graphic equalizer button under effects. I’ve finally decided this happens to my glitchiest projects and not the ones that have more normal levels. at least Audacity saves the projects when they shut down with less parts missing than before in previous versions, so i’m thankful for that. I can cause this at will but it’s just like the previous video I posted, so I don’t see the point in doing that again. thanks for your help.

See if you can reproduce the problem with the new Audacity 2.3.1 release candidate (see:

If you download the ZIP version, it does not need to be installed - just “extract” the contents of the ZIP file to somewhere convenient, then open the location where you extracted it. You should see a file called “audacity.exe”, which is the program file. Before running “audacity.exe”, create an empty folder in the same location as audacity.exe, and name the folder “Portable Settings”. This will give you the “2.3.1 RC03” version of Audacity, without interfering with your current version.

Alternatively, you could download the “Audacity devel Windows EXE” version, and just install it over the top of your current version. This will upgrade your current version to “2.3.1 RC03”.

The full release version of Audacity 2.3.1 is expected within the next couple of weeks, assuming no serious problems are discovered with the release candidate.

thanks but it says i’m “not authorized to view this forum”. guess i’ll wait.

This link on the Windows section should work for you:


samesies :laughing:

I think I’ve found the problem. Try again now.