Crash on start up

I’ve got an old mac power pc G5, dual 2.3 ghz with 1 gB ram. I am running system 10.4.11.I have it in my garage and use it to digitize old tapes and records. Since upgrading to Audacity 2.1.0, the program does not launch. I’ve searched similar topics and have tried creating an audacity.cfg file (and pasting in some code that disables plug-ins), but the application still won’t launch. I’ve also tried moving all my plug ins out of library> audio > plugins, but still it won’t lauch.
The crash log says there is an incompatible library “libiconv.2.dylib.” Everything that I have looked up about this seems over my head. Does anyone have any ideas on how to fix this without getting too too technical.
Here is the crash log. Much Thanks in advance.

Host Name: power-mac-g5
Date/Time: 2015-05-16 00:30:51.881 -0700
OS Version: 10.4.11 (Build 8S165)
Report Version: 4

Command: Audacity
Path: /Applications/Audacity/
Parent: WindowServer [60]

Version: (

PID: 265
Thread: Unknown

Link (dyld) error:

Library not loaded: /usr/lib/libiconv.2.dylib
Referenced from: /Applications/Audacity/
Reason: Incompatible library version: Audacity requires version 7.0.0 or later, but libiconv.2.dylib provides version 5.0.0

Does Audacity 2.0.6 run? You can still get it from

We did not know this was an issue or what Audacity version it started in, but from what I can tell from online searches, you may need to upgrade to Leopard or Snow Leopard to get a version 7 of libiconv.2.dylib.

I checked the libiconv.2.dylib file attached here in otool and it is definitely version 7, and the file command says it contains ppc architecture, but this file is dangerous because even trying to replace the system copy of it in /usr/lib while it’s in use could just break your system. Don’t try it.

The only thing I could suggest is that you put the libiconv.2.dylib from the above link in the folder you’re running Audacity from and see if it will use it instead. I somewhat doubt it.

I can ask someone who uses Tiger about this - but until then let us know about 2.0.6 or about putting the replacement dylib file in the Audacity folder.