Crackling playback, Mac OSX Yosemite


Sorry, but I don’t know where to post this - please help me put it where it belongs.

Just want to share that I had crackling noises when I played back files in Audacity 2.0.6 (and 5 as well). It didn’t matter whether I recorded them in Audacity or in another program - and the noises weren’t there when played back in Amadeus or iTunes or any other program.
So it is merely a playback problem. I tried changing settings as described elsewhere here - no effect.

I downgraded to 2.0.3. - problem solved.
I have no idea why it works, but it does. I go for the easy fix. If someone can fix the newer version, it would be great - until then I’ll use the old one.

My set up:
Mac OS x Yosemite
Duet firewire

Thanks, for a great program.

What settings - Audio to buffer?

Were these multi-track projects where some of the tracks did not start at time zero or had empty space elsewhere in them (not just silence)?

If so there is a fix for that if you would like to try the latest 2.1.0-alpha build from the top of the following page:

The fix may help some other types of playback problem on Mac, we are not sure.

Those are not release builds, so it may be best just to try the zip version out if you can, rather than use it for production.

Audacity does not yet officially support Yosemite. The latest alpha builds do enable Apple Audio Units to work in Audacity on Yosemite, but if you find any other problems in the alpha builds on Yosemite, please start a new topic in this Mac board and let us know there.


Hi again,

I can’t find the post now, but I tried everything you suggested someone else with at similar problem:
Adjusting bit-rate, real time conversion, audio to buffer separately and together - no effect.

They were not multi track recordings and there is no difference whether the recording starts at zero or not.

I don’t think it is a Yosemite problem. When I finally tried the 2.0.3 I was following this thread:
And he doesn’t use Yosemite as far as I can tell. (I am on a Mac Mini FYI).

I have a few other problems in Yosemite: I can’t use some of the plug ins (on the lower half of the menu in Effects) and it crashes after I finish one project, save and start at new one. I think other people have given that report too. (I have learned the hard way before and somehow managed to forget and do it again: I shouldn’t have updated to Yosemite. Duh!)


If you prefer, you can wait until Audacity 2.1.0 comes out sometime towards the end of January and see if playback is better in that version.

If you mean Audio Units, that should be fixed in the 2.1.0 version when it comes out.

Do you close the project before opening the new one? What are the exact steps that makes it happen?

Can you attach a crash report for one of those crashes from /Library/Logs/DiagnosticReports/ ? Please see here for how to attach files:


For me (Mavericks), Gale’s advice to increase the record buffer size in preferences fixed the crackling noises - mine is set to 20ms and the annoying crackling disappeared.

OMG. Now I tried updating to Audacity 2.1.0, which should be ok for Yosemite and the problem is back.
Any file I open in Audacity plays back with crackling noises. They are not there in Amadeus or Itunes or other programs.

So far this is the only problem I’ve encountered with 2.1.0 and my plug-ins work again, which they didn’t before in Yosemite.

Any ideas? It obviously doesn’t effect the recording quality, but makes it a bit of a task to edit in Audacity listening to all the crackling.


What is the playback device? Does the crackling occur only when you play back to the Duet, or does the crackle also occur when playing to the built-in audio?

I don’t have any fresh suggestions. If you are using the Duet it is important that the playback sample rate set for Duet in Audio MIDI Setup is the same as the Audacity project rate.

What sample rate are the files? You can check by looking in the Track Control Panel to left of the blue waves in Audacity. If you play to the Duet and the rate shown is the track is the same as the Audacity project rate bottom left, and that is also the same rate set for the Duet in Audio MIDI Setup, is there still crackling?

Audio to buffer in Audacity’s Recording Preferences may need to be adjusted carefully. There is a good chance that if you find the “sweet spot setting” that the crackling will stop. Reduce the value to 0 and work upwards from there in 10 millisecond increments.


You’re a genius. I changed the Audio to buffer latency to 10 milliseconds and the crackling stopped.

Thank you!