Crackling/clicks heard on all files

Hi. I’ve been using Audacity for a few years on Windows and successfully did so on Linux Mint 17 for a few months. Then all of a sudden (I don’t know what caused it) it started to malfunction. All files, whether old or new, imported audio formats or recorded directly with a mike, are full of clicks and crackles. If I then export the file as an audio file, these clicks and crackles are no longer audible. But it does make it impossible to work with. The programme also crashes spectacularly frequently, with no apparent reason. I recently updated to V 2.1.1 hoping it would resolve these issues, but no such luck. Any ideas?

Audacity Version: 2.1.1
Operating System: Linux Mint 17.1 Cinnamon 64-bit
Cinnamon Version: 2.4.8
Linux Kernel: 3.13.0-37
Processor: AMD E-350 APU with Radeon HD Graphics x 2
Memory: 3.4 GiB
Hard Drive: 476.3 GB

What are your “Latency” settings in “Edit > Preferences > Recording”? The default “Audio to buffer” is 100. Smaller values may cause crackling.
I presume that you are not using Jack?
In the device toolbar, try setting the playback device to the “hw” option.

Thanks for your reply Steve.

I’ve just tried playing with the latency settings, but it doesn’t seem to change anything. Also tried all the playback options on the device toolbar, also to no avail.

No jack; usually I record in WAV on a zoom H4N then import to Audacity from the SD Card, although to test it I’ve also tried connecting a mike direct through the jack and I have the same problem. It seems that the crackles/clicks/dropouts are a problem only on playback, because as I say when I then export as an audio format such as WAV or MP3 they disappear.

Could it be a problem with ALSA?

That’s unlikely if playback is ok in other applications.
Have you tried the “hw” option as suggested?

Yes I have. I have a choice of HD-Audio generic HDMI 0(hw:0,3); HDA ATI SB: ALC662 rev1 Analogue (hw:1,0); HDMI; pulse and default. I’ve tried all of them and nothing works. The latency was set to 0 but I’ve changed that to 100 and it still doesn’t work.

I presume that is a typo (you can check the version number in “Help > About Audacity”).

The fact that it was working and then it wasn’t indicates that “something” has changed. We need to try and work out “what”.
Are you running short of disk space?
Have you added or changed any hardware?
Are you running other programs at the same time?
Are you using the same audio output?
Anything you can think of that may have changed?

No typo, I’ve rechecked and it’s definitely 2.1.1

I was running out of disk space, and thought that might be the problem, so I offloaded a load of files to an external drive, now I’m using about 225 GB of a total of 488 GB.

No modifications to the hardware.

The problem occurs whether or not I run other programs at the same time. (I think I’m right about that, after I’ve posted I’ll close this browser and try it out to make sure.)

When you talk about the same audio output, I’m not sure what you mean? I usually use VLC to play my audio files, either through the speakers or headphones. Audacity plays through those as well.

The only things that may have changed are that 1) I regularly install system updates on my computer 2) I may possibly have inadvertently changed some parameters in Audacity, but I’ve tried playing with a lot of settings and really get the impression that this is a bug, especially as it crashes so often.

Don’t forget that this problem started before I updated to the current version, so I’m presuming this is a compatibility issue between a Mint update and Audacity. Does that seem a reasonable assumption?

I’ve just checked if it still happens with no other programmes running - it does.

Also, I’ve noted that the crackling/clicks are inconsistent, i.e. they occur at different points each time the file is played back. So it’s not a corruption of the file itself.

Have you tried disabling HDMI?

In my experience, this is a very confusing option that sometimes interferes with the usual line outputs. I once spent almost a week troubleshooting a USB audio interface on one of the first laptops with a HDMI output. That one wasn’t even capable of outputting audio over HDMI.

I didn’t think that Mint had 2.1.1 yet, or did you install it some other way than from the standard repository?

It would appear that your computer has both Realtek ALC662 and HDMI.
Is it a laptop computer?
Where does the sound come out?

If you don’t use the HDMI audio you can try disabling that as cyrano suggested, and if you don’t use bluetooth you could try disabling that. (I’ve known cases where either of these can interfere with the sound card).

I think we’re talking at cross purposes here, I meant Audacity V. 2.1.1, not Mint! My version of Mint is 17.1.

No, it’s not a laptop; I have a pair of speakers plugged in with a jack connection. I’ve just checked in System Settings and found that Bluetooth doesn’t appear to be enabled “No Bluetooth adapters found” and that “HDMI/DisplayPort Built-In Audio” is not selected. When I do select it in order to test the sound, it doesn’t work anyway. So my output is “Analogue Output Built-In Audio” and that works fine on the test. But not on Audacity obviously!

What “project rate” are you using? (bottom left corner of the main Audacity window). The default is 44100.

What “project rate” are you using? (bottom left corner of the main Audacity window). The default is 44100.

Yes it’s 44100.

I’m running out of ideas.

Try resetting the Audacity preferences (With Audacity closed, find the hidden file “~/audacity-data/audacity.cfg” and delete it.)
Ensure that no other audio applications are running.
Then start Audacity and set the recording and playback devices in the device toolbar to the “hw” option that corresponds to your sound card (probably “hw:1,0” from what you wrote previously).

Wow! I think that’s worked! Been too busy for the last 10 days to do anything, but Steve I’ve just seen your last post, deleted audacity.cfg, left the playback device on default and the problem’s gone. Brilliant, thanks so much! I just hope it will help to stop Audacity crashing on me as well ?!