Crackling audio playback - multiple formats and volume level

Mac Pro (early '08)
2x2.8 Quad Xeon
IOS X - 10.8.5
Audacity builds 2.0.4 & 2.0.5

Steps to reproduce:

  1. Open any existing audio file, in either .wav, .aif or .mp3 format.
  2. Start playback.

Expected results:
File is played back and sounds identical to the way it sounds in other editors, DAWs and MP3 Players.

Actual results:
Playback has very audible “crackling” noise.


  1. This clicking / crackling sound is occurring on audio files that have been recorded / generated on other software. I’ve experienced this on several files that all play back with no defects on every other audio program I have.
  2. To my ear, the crackling behavior does not seem to be related to the source material (i.e. the noise does not get better or worse when file is: edited, during louder or quieter sections, or with different file formats.
  3. This issue has nothing to do with recording levels as the files have already been recorded. This is a playback issue.
  4. After experiencing the “crashing while opening file” bug that was plaguing 2.0.4, I’ve fully uninstalled that version and reinstalled 2.0.5. Happy to report that the problem opening files seems to have been resolved (at least on my platform), but the crackling audio persists.

Any help on this issue would be greatly appreciated. I’m a… “Stranded” former Peak user that has no Mac compatible 2-track editor solution.

Thanks in advance!


We do have a few reports of “choppy” or “stuttering” playback in 2.0.4 on OS X , but the problem is not reproducible on any of our machines.

So I hope you won’t mind a few questions.

What application produced the problem files? Are you using Soundflower?

If you import audio into Audacity that sounds OK in other players, then export it from Audacity as 16-bit WAV at 44100 Hz project rate (see bottom left of the Audacity window), and then play it in iTunes, does it still sound OK?

Do you drag the audio rightwards after importing it into Audacity, so that there is white space in the track before the audio waveform starts?

Do you have multiple files in one project window?

If you Tracks > Mix and Render the imported audio in Audacity, does that stop the crackle?

Exactly what device are you using for playback? What are your settings for that device in /Applications/Utilities/Audio MIDI Setup? What Audacity project rate do you usually use?

Do you have Transport > Overdub (on/off) switched on (checked)? If so, does turning Overdub off help?

Can you provide a link to an example file that crackles when you play it in Audacity? For example, you could upload it to dropbox, or similar.


This is a playback issue.

Can we assume it doesn’t crackle in the same place every time? Does it continue to crackle if you pause the playback?

Is there any reaction if you use the Speed Playback slider.

I know what the goal is, but can you make it worse?

Screen shot 2013-10-09 at 4.59.51 PM.png

OK. Open Audacity > Preferences, choose “Quality” on the left and ensure “Default Sample Rate” is 44100 Hz. In “Default Sample Format”, try 24-bit or 32-bit float. In Audio MIDI Setup (output side), leave the device set at 44100 Hz 24-bit, but choose 2-ch (stereo).

If that still has crackle/stutter, use 16-bit Default Sample Format in Audacity, and 44100 Hz 16-bit 2-ch in Audio MIDI Setup.

If that still has crackle/stutter, in the Audacity “Quality” Preferences under “Real-time Conversion”, set “Sample Rate Converter” to “Low quality (fastest)”.

If every file does this in Audacity, I assume at the moment that it is not a specific file problem, but what are the source of the files? If they are recordings, did you record using the DAW’s you mentioned, do the iTunes files come from files downloaded from the web or purchased from Apple, and so on?


I don’t really have too much more by way of suggestion, but it seems from the Ensemble documentation that there is no choice of bit depth provided by Apogee, nor do they suggest changing it in the DAW.

Have you tried 24-bit default sample format and 192000 Hz default sample rate in Audacity, stereo recording, with 2-ch 192000 Hz in Audio MIDI Setup?

Have you tried different audio to buffer settings in Audacity > Preferences: Recording section?


Hi Gale,

Sorry for the late reply. Just to close the loop on this topic, yes… I have tried all of these options and many more. It just looks to me that the combination of Apple, Apogee and Audacity doesn’t work so well. I’ll keep my eye out for future updates, but for now I’ve got to try to find something else that will work with the rig I’ve got.

Thanks for all your help!

I quite understand. I’ve no idea what else to suggest, except make a special build for you that changes a small piece of Audacity code that a developer has said (possibly) looks suspect.


For completeness, no-one suggested resetting preferences. It seems to have worked for one user in another topic Deleting the preferences file for audacity on the mac . I wouldn’t expect it to work in your case given you have already checked sample rates and formats.

However for anyone who wants to reset preferences on Mac:

  1. Audacity > Quit Audacity.
  2. Open Finder, Go > Go to Folder and type:
~/Library/Application Support/audacity/
  1. Open audacity.cfg in Textedit or other text editor.
  2. Select all the content of audacity.cfg then delete that content.
  3. Select and copy the following text, then paste it at the top of audacity.cfg:
  1. Save audacity.cfg and start Audacity.


I was having the same ‘stuttering’ problem with 2.0.5 on OS X 10.9 on a 2.4GHz Dual Core iMac.
Deleting the preferences didn’t solve it for me.
In my case turning the default sample rate down to 22050 solved the problem. My old version of Audacity 1.3.12 Beta works fine at 96000 (Can’t say anything about intermediate versions though - I am an intermittent user!)
It looks to me that Audacity 2.0.5 needs a lot more processing power than older versions to achieve the higher data rates, even for basic recording.

Thanks, Ali. I would be very surprised if that was true. It would be true comparing Audacity 1.2 with 1.3 and 2.0.x.

Please tell us exactly what device you are recording and playing back with. Almost everyone that complains about various Mac playback problems are using external USB or Firewire devices and the problem goes away when using the built-in audio. Is that the case for you?

Is it a recording problem or a playback problem? If you export a recording from Audacity that plays with stutters, does it stutter when you play it in iTunes?

If you open Finder, choose Go > Utilities then open “Audio MIDI Setup”, are you sure you have input and output sample rate and bit depth matched with Default Sample Rate and Default Sample Format in Quality Preferences ?

Are you sure Mavericks is responding fast enough? Some users who have upgraded from earlier versions of Mac OS X find they have to reinstall Mavericks to fix crashes and unresponsiveness.

And does your device support Mavericks, or have you obtained the latest device firmware for Mavericks?

Another thing you could do is try is Audacity 2.0.1 ( ) and Audacity 2.0.2 ( ). Do either of those versions play (or record) without stutter at 96000 Hz? Most people who complain think that the problem started in 2.0.3 or 2.0.4. If so we need to identify exactly when this problem started.


In my case turning the default sample rate down to 22050 solved the problem.

Our traditional crackling problems are caused by the computer not going fast enough for live audio. Pieces get dropped during the course of the playback. The D/A converter hits a dead spot in the stream and goes briefly nuts. Some machines stutter as they simply repeat the last known data until something new comes along.

In the above case, the bitstream would have slowed down to the point that playback survived. That’s not optimal because 22050 has the sound quality of AM radio. The computer needs to speed up to meet the show, not slow down the show to match the computer.


That’s why I asked if you could make it worse. Gazing intently at one part of the problem sometimes leads you to a hole (like you have now) instead of success.

Launch Photoshop and a large picture, two web browsers and iTunes, the Dictionary and Activity Monitor all at once – and Audacity. Play a tune. Does the crackling get worse?

Is your desktop a minefield with billions of icons on it? You can seriously slow down your computer by doing that.


Thanks for the suggestions. The crackling issue is not affected by the load on the machine. The issue is identical if Audacity is the only application running or if (as I just tested) I have Audacity, Logic, Photoshop, Premier, Safari (multiple windows), Firefox (multiple windows), iTunes and Maestro running (going for a serious load test).

Thanks again.


Did you try 2.0.2 or 2.0.3 to see if you can identify which version the crackling started in: ?

Which editing software are you using now that does not crackle?


I am also getting “choppy” or “stuttering” playback in 2.0.5 on OS X.(using a 2009 iMac with latest OSX 10.9)
I had downloaded the .dmg installer
The problem occurred with an audacity file i had created in version 1.3.13
I followed the suggestions already suggested but had no luck.
When I reinstalled Version 1.3 playback was smooth and normal - phew!!!

Are you sure the problem isn’t only with that project?

What device are you using for playback? Is it the built-in output or an external playback device?

It is not recommended to use 1.3 versions of Audacity because they are Beta versions and have many bugs.

Please try 2.0.2: and 2.0.3: and tell us if either version has crackly playback.

Given no-one on Audacity Team can reproduce the problem it will not be fixed unless someone points us to the Audacity 2.x version where the problem was introduced.


Hi Gale
The problem that occurred with 2.05 was with all my projects - I had about 10 stored and all had the same problem - they were all created in 1.3.
I was using my built-in output for playback.
I downloaded version 2.03 and it is working fine now - no problems
I reinstalled version 2.05 from the zip download and it had the same problem as previously reported.
One thing is that I noticed that when I first started version 2.03 and 2.05 after installation that the process was a little different in that version 2.05 went through a list of all the plug-ins on my hard drive and installed them one by one while version 2.03 seemed to load them behind the scenes (so to speak)

Thanks for testing. Can you quit whichever Audacity version you are using now and try Audacity 2.0.4. Does that stutter?

In the versions that have stutter, does Audacity > Preferences, choose “Recording”, then increase the “Audio to Buffer” prevent the stutter? That setting affects playback as well as recording, but to test, make sure Transport > Software Playthrough is off (not ticked) .

Yes that is correct for VST plug-ins. See Audacity Manual . Audacity no longer loads VST effects automatically on first run because an incompatible plug-in could cause Audacity not to start. With the list you can choose which VST plug-ins to install.

Audio Unit plug-ins are now scanned in the background when you start Audacity but they only load when you choose them from the Effect Menu.