Crackles on recorded tracks

Hi everyone, I am having problems with a new install of Audacity 2.0.5

Windows XP SP3 (32-bit)

At first I had latency issue, so I adjusted that so my tracks would line up correctly (ended up having to be -116) so that’s fixed… but…

Here’s the deal, tracks that I have recorded have very noticable crackling and popping on them. I tried recording in Reaper just to see if this was a soundcard issue, and everything sounds fine in that program. This didn’t happen on the pc that I previously had this sound card installed on, and now all of the sudden there it is. I’m plugging guitar into the card and recording and the crackles show up every single time.

I do not hear the crackling in my headphones while I record at all. Just when I playback what I have just recorded.

I have tried updating my sound card drivers (it’s an old Audigy 2 ZS), different cables, using a different line into the sound card, and nothing.

Like I said, it has to be Audacity, because other programs are not giving me any crackle at all.

I am attaching a file so you can hear it for yourselves.

https://www.dropbox.com/s/1fzcscwyqqyweah/crackle.wav

I’d really appreciate any help. I just put this PC together after a ton of other problems a month ago so I could get recording again, and now I can’t fix this problem for the life of me.

This thread may help: https://forum.audacityteam.org/t/getting-distortion-on-audio-recording-guitar-and-vocal/35211/1

Once a solution gets posted

But if that is the case with yours too - then see this FAQ: http://manual.audacityteam.org/o/man/faq_recording_troubleshooting.html#skips
WC

I don’t think you have skips.

Have you tried adjusting “Audio to buffer” in Recording Preferences?

Have you tried a different host in Device Toolbar?

Have you tried 44100 Hz project rate and setting Audigy to 44100 Hz?

Also please be careful with Windows XP. Microsoft are no longer officially supporting it, so it will be unpatched against any new security vulnerabilities (viruses) that appear. A virus may already
be causing the recording problem, by using computer resources to spy on you or to use your computer to send spam e-mails over the internet.

Ensure you have a good third-party anti-virus application, and run a deep scan that runs when you reboot the computer. But be aware that it will not give you complete protection against a previously unknown attack.

If it is not practicable for you to update to the much more secure Windows 7 or Windows 8, you can consider installing a Linux operating system instead. Most versions are free and all are very secure.


Gale

Audio to buffer is one thing I’d like to experiment with, but I am not sure what settings to start with. It’s set to the default right now and I’m not sure if I should be bumping the number up or down. A little help there would be great.

Not sure what you mean by a different host in the device toolbar, but I have tried using an entirely different input (the Audigy has a front dock that I usually plug my guitar into, I also tried going through the back straight into the soundcard. Still get the crackle. It seems like my card and Audacity are having some sort of problem. Like I said what’s weird is this crackle is only after I play a track back that I have recorded. There is no crackle in the phones while I am actually recording the track.

I have tried recording in mono, and nothing.

If there is a way to set the Audigy to 44100 Hz I am not aware of it.

I’m going to doubt viruses are the case because this is a brand new install of XP, and there is barely anything installed on it besides Audacity and basic web browsers.

Last night I tried an older version of Audacity and also an older version of my soundcard drivers and that did not fix the problem as well.

I am going to try using my usb mic today and see if that also crackles. I will let you know how it goes. That will take my soundcard totally out of the situation. I am not against just getting a different soundcard if I THINK that it would clear up this problem. I prefer to plug my guitar directly into the card because then everyone else in the house doesn’t have to listen to me play, but I suppose I could start using a mic on my amp if it comes down to it. This just seems like a problem with a reason to it, and I really wish I knew why it suddenly is happening.

The obvious answer would be to increase it, but it may be conflicting with a buffer or latency setting in Audigy. I suggest you try increasing the value and then decreasing it if increasing does not help.

I mean a different host in Device Toolbar. See Device Toolbar - Audacity Manual . If you are using MME, try Windows DirectSound and vice-versa.

If it comes with a manual, look at it. Does it have a control panel in Windows?

Web browsers are the problem. XP is now unsafe if connected to the internet.


Gale

Tried a few more things. First of all I moved the card to a different PCI slot just in case… didn’t work.

Played with buffer settings, nothing.

I had already tried windows direct sound and mme.

Tried my usb mic and it worked fine, so there’s always playing through an amp, but I really want to figure this out. Same card worked fine in my other computer and for some reason it just won’t work with this one.

Do you have the latest and most appropriate drivers for this Audigy card downloaded from the Creative web site?

There must be a reason why Reaper does not have the problem. It is most likely to be that it is using Windows WDM-KS or ASIO. Audacity 2.0.4 gives you a WDM-KS host, but there is a chance that WDM-KS could freeze your computer if the motherboard sound device does not like it.

You can compile Audacity with ASIO support. See ASIO Audio Interface - Audacity Wiki .


Gale